CVE-2022-24953
Crypt_GPG does not prevent additional options in GPG calls
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.3
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
CVE-2022-24953- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:N/I:P/A:N - Weakness
- CWE-88
- Updated
- 2026-11-02
CVE List No score
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
CVE-2022-24953- Updated
- 2026-11-02
EUVDEUVD-2022-0836 No score
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
EUVD-2022-0836- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-59x4-67mh-px54
5.3
Crypt_GPG does not prevent additional options in GPG calls
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
GHSA-59x4-67mh-px54- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-24953
5.3
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
DEBIAN-CVE-2022-24953- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-03
OSVGHSA-59x4-67mh-px54
5.3
Crypt_GPG does not prevent additional options in GPG calls
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
GHSA-59x4-67mh-px54- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-24953
5.3
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
UBUNTU-CVE-2022-24953- CVSS 3.1
- 5.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSV No score
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
- Record
CVE-2022-24953- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
pear/crypt_gpgPackagist |
before 1.6.7 | 1.6.7 |
php-crypt-gpgDebian:12 |
before 1.6.7-1 | 1.6.7-1 |
php-crypt-gpgDebian:13 |
before 1.6.7-1 | 1.6.7-1 |
php-crypt-gpgDebian:14 |
before 1.6.7-1 | 1.6.7-1 |
pear/crypt_gpgPackagist |
before 1.6.7, plus listed versions v1.4.0v1.4.1v1.4.2v1.4.3v1.6.0 Show 9 moreShow lessv1.6.0b1v1.6.0b2v1.6.0b3v1.6.1v1.6.2v1.6.3v1.6.4v1.6.5v1.6.6 |
1.6.7 |
php-crypt-gpgUbuntu:16.04:LTS |
All versions, plus listed versions 1.3.2-11.4.0-11.4.0-1ubuntu11.4.0-1ubuntu2 |
None known |
php-crypt-gpgUbuntu:22.04:LTS |
All versions, plus listed versions 1.6.4-21.6.6-1build11.6.7-11.6.7-2 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-24953 is a medium vulnerability (CVSS 5.3) in Pear Crypt Gpg, published February 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.85%, the 58th percentile. Fixed in pear/crypt_gpg 1.6.7.
References
github.com/pear/Crypt_GPG/commit/74c8f989cefbe0887274b461dc56197e121bfd04
github.com/pear/Crypt_GPG/commit/29c0fbe96d0d4063ecd5c9a4644cb65a7fb7cc4e
nvd.nist.gov/vuln/detail/CVE-2022-24953
github.com/advisories/GHSA-59x4-67mh-px54
github.com/CVEProject/cvelistV5/tree/main/cves/2022/24xxx/CVE-2022-24953.json
security-tracker.debian.org/tracker/CVE-2022-24953
github.com/pear/Crypt_GPG
ubuntu.com/security/CVE-2022-24953
cve.org/CVERecord?id=CVE-2022-24953