Every CVE Search/ Get API key

CVE-2022-25326

Denial of Service in fscrypt

5.5 MediumFix available

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.13%Down 0.8 points since Feb 26, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.5

Denial of Service in fscrypt

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
CVE-2022-25326
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
EUVDEUVD-2022-1106 5.5

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
EUVD-2022-1106
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-mpq4-rjj8-fjph 5.5

Uncontrolled Resource Consumption in github.com/google/fscrypt

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
GHSA-mpq4-rjj8-fjph
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
GitHub AdvisoriesGHSA-chxf-fjcf-7fwp No score

Possible filesystem space exhaustion by local users

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt v0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

For more details, see CVE-2022-25326 and https://github.com/google/fscrypt#setting-up-fscrypt-on-a-filesystem.

Record
GHSA-chxf-fjcf-7fwp
Updated
2026-11-02
NVD 5.5

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
CVE-2022-25326
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-400
Updated
2026-11-02
OSV 5.5

Denial of Service in fscrypt

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
CVE-2022-25326
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2022-25326 5.5

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
DEBIAN-CVE-2022-25326
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVGHSA-mpq4-rjj8-fjph 5.5

Uncontrolled Resource Consumption in github.com/google/fscrypt

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
GHSA-mpq4-rjj8-fjph
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVUBUNTU-CVE-2022-25326 5.5

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt 0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

Record
UBUNTU-CVE-2022-25326
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-chxf-fjcf-7fwp No score

Possible filesystem space exhaustion by local users

fscrypt through v0.3.2 creates a world-writable directory by default when setting up a filesystem, allowing unprivileged users to exhaust filesystem space. We recommend upgrading to fscrypt v0.3.3 or above and adjusting the permissions on existing fscrypt metadata directories where applicable.

For more details, see CVE-2022-25326 and https://github.com/google/fscrypt#setting-up-fscrypt-on-a-filesystem.

Record
GHSA-chxf-fjcf-7fwp
Updated
2026-11-02
OSVGO-2022-0339 No score

Possible filesystem space exhaustion by local users in github.com/google/fscrypt

Possible filesystem space exhaustion by local users in github.com/google/fscrypt

Record
GO-2022-0339
Updated
2026-11-02
OSVopenSUSE-SU-2024:11902-1 No score

fscrypt-0.3.3-1.1 on GA media

These are all security issues fixed in the fscrypt-0.3.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11902-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/google/fscrypt
Go
before 0.3.3
0.3.3
fscrypt
Debian:12
before 0.3.3-1
0.3.3-1
fscrypt
Debian:13
before 0.3.3-1
0.3.3-1
fscrypt
Debian:14
before 0.3.3-1
0.3.3-1
fscrypt
Ubuntu:18.04:LTS
All versions, plus listed versions
0.2.2-0ubuntu20.2.2-0ubuntu2.1
None known
fscrypt
Ubuntu:20.04:LTS
All versions, plus listed versions
0.2.4-20.2.5-10.2.5-2
None known
fscrypt
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.3.3-1.1
0.3.3-1.1

History

History
RecordedChangedSources
affected, factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-25326 is a medium vulnerability (CVSS 5.5) in Google Fscrypt, published February 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.13%, the 2nd percentile. Fixed in github.com/google/fscrypt 0.3.3.

References

Show 10 moreShow less
MoveEnter Open