Every CVE Search/ Get API key

CVE-2022-25327

Local Denial of Service in fscrypt PAM module

5.5 MediumFix available

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.11%Down 0.8 points since Feb 26, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.5

Local Denial of Service in fscrypt PAM module

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
CVE-2022-25327
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-255
Updated
2026-11-02
EUVDEUVD-2022-0926 5.5

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
EUVD-2022-0926
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-8vwm-8vj8-rqjf 5.5

User login denial of service in github.com/google/fscrypt

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
GHSA-8vwm-8vj8-rqjf
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-276
Updated
2026-11-02
GitHub AdvisoriesGHSA-p93v-m2r2-4387 No score

Denial of service via insufficient metadata validation

The PAM module for fscrypt through v0.3.2 doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to v0.3.3 or above.

For more details, see CVE-2022-25327.

Record
GHSA-p93v-m2r2-4387
Updated
2026-11-02
NVD 5.5

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
CVE-2022-25327
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
2.1 LowAV:L/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-255, CWE-276
Updated
2026-11-02
OSV 5.5

Local Denial of Service in fscrypt PAM module

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
CVE-2022-25327
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-255
Updated
2026-11-02
Show 6 moreShow less
OSVDEBIAN-CVE-2022-25327 5.5

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
DEBIAN-CVE-2022-25327
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVGHSA-8vwm-8vj8-rqjf 5.5

User login denial of service in github.com/google/fscrypt

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
GHSA-8vwm-8vj8-rqjf
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-276
Updated
2026-11-02
OSVUBUNTU-CVE-2022-25327 5.5

The PAM module for fscrypt doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to version 0.3.3 or above

Record
UBUNTU-CVE-2022-25327
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVGHSA-p93v-m2r2-4387 No score

Denial of service via insufficient metadata validation

The PAM module for fscrypt through v0.3.2 doesn't adequately validate fscrypt metadata files, allowing users to create malicious metadata files that prevent other users from logging in. A local user can cause a denial of service by creating a fscrypt metadata file that prevents other users from logging into the system. We recommend upgrading to v0.3.3 or above.

For more details, see CVE-2022-25327.

Record
GHSA-p93v-m2r2-4387
Updated
2026-11-02
OSVGO-2022-0340 No score

User login denial of service in github.com/google/fscrypt

User login denial of service in github.com/google/fscrypt

Record
GO-2022-0340
Updated
2026-11-02
OSVopenSUSE-SU-2024:11902-1 No score

fscrypt-0.3.3-1.1 on GA media

These are all security issues fixed in the fscrypt-0.3.3-1.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:11902-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
github.com/google/fscrypt
Go
before 0.3.3
0.3.3
fscrypt
Debian:12
before 0.3.3-1
0.3.3-1
fscrypt
Debian:13
before 0.3.3-1
0.3.3-1
fscrypt
Debian:14
before 0.3.3-1
0.3.3-1
fscrypt
Ubuntu:18.04:LTS
All versions, plus listed versions
0.2.2-0ubuntu20.2.2-0ubuntu2.1
None known
fscrypt
Ubuntu:20.04:LTS
All versions, plus listed versions
0.2.4-20.2.5-10.2.5-2
None known
fscrypt
openSUSE:Tumbleweed
From an advisory covering 3 CVEs
before 0.3.3-1.1
0.3.3-1.1

History

History
RecordedChangedSources
affected, factsOSV
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-25327 is a medium vulnerability (CVSS 5.5) in Google Fscrypt, published February 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.11%, the 1st percentile. Fixed in github.com/google/fscrypt 0.3.3.

References

Show 13 moreShow less
MoveEnter Open