Every CVE Search/ Get API key

CVE-2022-25640

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual...

7.5 HighPublic exploitFix available

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

1.35%Up 0.5 points since Feb 24, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
CVE-2022-25640
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Weakness
CWE-295
Updated
2026-11-02
CVE List No score

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
CVE-2022-25640
Updated
2026-11-02
EUVDEUVD-2022-30300 No score

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
EUVD-2022-30300
Updated
2026-11-03
GitHub AdvisoriesGHSA-wx9x-cpp6-2q3w 7.5

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual...

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
GHSA-wx9x-cpp6-2q3w
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-287
Updated
2026-11-02
OSVDEBIAN-CVE-2022-25640 7.5

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
DEBIAN-CVE-2022-25640
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-03
OSVJLSEC-2026-670 7.5

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
JLSEC-2026-670
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:P/A:N
Updated
2026-11-02
OSVUBUNTU-CVE-2022-25640 7.5

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
UBUNTU-CVE-2022-25640
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Updated
2026-11-02
OSV No score

In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.

Record
CVE-2022-25640
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wolfssl
Debian:12
before 5.2.0-1
5.2.0-1
wolfssl
Debian:13
before 5.2.0-1
5.2.0-1
wolfSSL_jll
Julia
before 5.7.2+0
5.7.2+0
wolfssl
Ubuntu:16.04:LTS
All versions, plus listed versions
3.4.8+dfsg-1
None known
wolfssl
Ubuntu:18.04:LTS
All versions, plus listed versions
3.10.2+dfsg-23.12.0+dfsg-13.12.2+dfsg-13.13.0+dfsg-1
None known
wolfssl
Ubuntu:20.04:LTS
All versions, plus listed versions
4.1.0+dfsg-24.2.0+dfsg-14.2.0+dfsg-24.2.0+dfsg-34.3.0+dfsg-2
None known
wolfssl
Ubuntu:22.04:LTS
All versions, plus listed versions
4.6.0-35.0.0-15.1.1-15.2.0-15.2.0-2
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubdim0x69/cve-2022-25640-exploit2022-03-16

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-25640 is a high vulnerability (CVSS 7.5) in Wolfssl, published February 24, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.35%, the 71st percentile. Fixed in wolfssl 5.2.0-1.

References

MoveEnter Open