Every CVE Search/ Get API key

CVE-2022-25770

Insufficient authentication in upgrade flow

7.8 HighFix available

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
High
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
High

Exploit likelihood

0.28%Up 0.2 points since Sep 19, 2024
90%50%10%1%

What each source reports

CVE List Score used 7.8

Insufficient authentication in upgrade flow

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
CVE-2022-25770
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02
EUVDEUVD-2024-2721 7.8

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
EUVD-2024-2721
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Updated
2026-11-03
GitHub AdvisoriesGHSA-5hc5-fxr9-5frc 7.4

Duplicate Advisory: Mautic has insufficient authentication in upgrade flow

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-qf6m-6m4g-rmrc. This link is maintained to preserve external references.

Original Description

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
GHSA-5hc5-fxr9-5frc
CVSS 4.0
7.4 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02
GitHub AdvisoriesGHSA-qf6m-6m4g-rmrc 5.1

Mautic has insufficient authentication in upgrade flow

Impact

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable

Patches

Please upgrade to 4.4.1 or 5.1.1 or later.

Workarounds

None.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-qf6m-6m4g-rmrc
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02
NVD 7.8

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
CVE-2022-25770
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-306
Updated
2026-11-02
OSV 7.8

Insufficient authentication in upgrade flow

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
CVE-2022-25770
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02
OSVGHSA-5hc5-fxr9-5frc 7.4

Duplicate Advisory: Mautic has insufficient authentication in upgrade flow

Duplicate Advisory

This advisory has been withdrawn because it is a duplicate of GHSA-qf6m-6m4g-rmrc. This link is maintained to preserve external references.

Original Description

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable.

Record
GHSA-5hc5-fxr9-5frc
CVSS 4.0
7.4 HighCVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02
OSVGHSA-qf6m-6m4g-rmrc 5.1

Mautic has insufficient authentication in upgrade flow

Impact

Mautic allows you to update the application via an upgrade script.

The upgrade logic isn't shielded off correctly, which may lead to vulnerable situation.

This vulnerability is mitigated by the fact that Mautic needs to be installed in a certain way to be vulnerable

Patches

Please upgrade to 4.4.1 or 5.1.1 or later.

Workarounds

None.

For more information

If you have any questions or comments about this advisory:

Record
GHSA-qf6m-6m4g-rmrc
CVSS 4.0
5.1 MediumCVSS:4.0/AV:L/AC:H/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:H
Weakness
CWE-306
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
mautic/core
Packagist
1.0.0-beta3 up to 4.4.13
4.4.13
mautic/core
Packagist
5.0.0-alpha up to 5.1.1
5.1.1
mautic/core-lib
Packagist
1.0.0-beta3 up to 4.4.13
4.4.13
mautic/core-lib
Packagist
5.0.0-alpha up to 5.1.1
5.1.1
mautic/core
Packagist
1.0.0-beta3 up to 4.4.13, plus listed versions
1.0.01.0.0-beta41.0.0-rc11.0.0-rc21.0.0-rc3
Show 45 moreShow less
1.0.0-rc41.0.11.0.21.0.31.0.41.0.51.1.01.1.11.1.21.1.31.2.01.2.0-beta11.2.11.2.21.2.31.2.41.3.01.3.11.4.01.4.12.0.02.0.12.1.02.1.12.10.02.10.0-beta2.10.12.11.02.11.0-beta2.12.02.12.0-beta2.12.12.12.1-beta2.12.22.12.2-beta2.13.02.13.0-beta2.13.12.14.02.14.0-beta2.14.12.14.1-beta2.14.22.14.2-beta2.15.0
4.4.13
mautic/core
Packagist
5.0.0-alpha up to 5.1.1, plus listed versions
5.0.05.0.0-alpha15.0.0-beta15.0.0-beta25.0.0-rc1
Show 6 moreShow less
5.0.0-rc25.0.15.0.25.0.35.0.45.1.0
5.1.1
mautic/core-lib
Packagist
1.0.0-beta3 up to 4.4.13, plus listed versions
4.0.04.0.0-alpha14.0.0-beta4.0.0-rc4.0.1
Show 27 moreShow less
4.0.24.1.04.1.14.1.24.2.04.2.0-rc4.2.0-rc14.2.14.2.24.3.04.3.0-beta4.3.0-rc4.3.14.4.04.4.14.4.1-alpha4.4.104.4.114.4.124.4.24.4.34.4.44.4.54.4.64.4.74.4.84.4.9
4.4.13
mautic/core-lib
Packagist
5.0.0-alpha up to 5.1.1, plus listed versions
5.0.05.0.0-alpha15.0.0-beta15.0.0-beta25.0.0-rc1
Show 6 moreShow less
5.0.0-rc25.0.15.0.25.0.35.0.45.1.0
5.1.1

History

History
RecordedChangedSources
affected
affected, aliases, published, referencesEUVD
first indexedGitHub Advisories, OSV
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-25770 is a high vulnerability (CVSS 7.8) in Acquia Mautic, published September 18, 2024. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.28%, the 20th percentile. Fixed in mautic/core 4.4.13.

References

This page doesn't list everything

Left out here: 97 versions. The JSON record has them.

MoveEnter Open