CVE-2022-25838
Multi-Factor Authentication issue in Laravel Fortify
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.1
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
CVE-2022-25838- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:P - Weakness
- CWE-294
- Updated
- 2026-11-02
CVE List No score
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
CVE-2022-25838- Updated
- 2026-11-02
EUVDEUVD-2022-0873 No score
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
EUVD-2022-0873- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-6w4v-qr4m-97gg
8.1
Multi-Factor Authentication issue in Laravel Fortify
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
GHSA-6w4v-qr4m-97gg- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-294
- Updated
- 2026-11-02
OSVGHSA-6w4v-qr4m-97gg
8.1
Multi-Factor Authentication issue in Laravel Fortify
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
GHSA-6w4v-qr4m-97gg- CVSS 3.1
- 8.1 High
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-294
- Updated
- 2026-11-02
OSV No score
Laravel Fortify before 1.11.1 allows reuse within a short time window, thus calling into question the "OT" part of the "TOTP" concept.
- Record
CVE-2022-25838- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
laravel/fortifyPackagist |
before 1.11.1 | 1.11.1 |
laravel/fortifyPackagist |
before 1.11.1, plus listed versions v0.0.1v1.0.0v1.0.1v1.1.0v1.10.0 Show 38 moreShow lessv1.10.1v1.10.2v1.11.0v1.2.0v1.2.1v1.3.0v1.3.1v1.4.0v1.4.1v1.4.2v1.4.3v1.5.0v1.6.0v1.6.1v1.6.2v1.7.0v1.7.1v1.7.10v1.7.11v1.7.12v1.7.13v1.7.14v1.7.2v1.7.3v1.7.4v1.7.5v1.7.6v1.7.7v1.7.8v1.7.9v1.8.0v1.8.1v1.8.2v1.8.3v1.8.4v1.8.5v1.8.6v1.9.0 |
1.11.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-25838 is a high vulnerability (CVSS 8.1) in Laravel Fortify, published February 24, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.95%, the 61st percentile. Fixed in laravel/fortify 1.11.1.
References
github.com/laravel/fortify/issues/201
nvd.nist.gov/vuln/detail/CVE-2022-25838
github.com/laravel/fortify/pull/357
github.com/laravel/fortify/pull/358
github.com/FriendsOfPHP/security-advisories/blob/master/laravel/fortify/CVE-2022-25838.yaml
github.com/advisories/GHSA-6w4v-qr4m-97gg
github.com/CVEProject/cvelistV5/tree/main/cves/2022/25xxx/CVE-2022-25838.json
github.com/laravel/fortify