CVE-2022-25873
Cross-site Scripting (XSS)
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.6
Cross-site Scripting (XSS)
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
CVE-2022-25873- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:P - Updated
- 2026-11-02
EUVDEUVD-2022-6907
4.6
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
EUVD-2022-6907- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:P - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q4q5-c5cv-2p68
5.4
Vuetify Cross-site Scripting vulnerability
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
GHSA-q4q5-c5cv-2p68- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
4.6
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
CVE-2022-25873- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N - CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.6
Cross-site Scripting (XSS)
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
CVE-2022-25873- CVSS 3.1
- 4.6 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N/E:P - Updated
- 2026-11-02
OSVGHSA-q4q5-c5cv-2p68
5.4
Vuetify Cross-site Scripting vulnerability
The package vuetify from 2.0.0-beta.4 and before 2.6.10 are vulnerable to Cross-site Scripting (XSS) due to improper input sanitization in the 'eventName' function within the VCalendar component.
- Record
GHSA-q4q5-c5cv-2p68- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVCLSA-2026-1775176070 No score
TuxCare security update for 2 packages (2 CVEs)
TuxCare rebuilt 2 packages to address 2 CVEs. Fixed in 2.5.5-tuxcare.1.
- Record
CLSA-2026-1775176070- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
vuetifynpm |
2.0.0-beta.4 up to 2.6.10 | 2.6.10 |
org.webjars.npm:vuetifyMaven |
2.0.0-beta.4 up to 2.6.10 | 2.6.10 |
@vuetify/api-generatorTuxCare:npm From an advisory covering 2 CVEs |
2.5.5-tuxcare.0 up to 2.5.5-tuxcare.1, plus listed versions 2.5.5 |
2.5.5-tuxcare.1 |
vuetifyTuxCare:npm From an advisory covering 2 CVEs |
2.5.5-tuxcare.0 up to 2.5.5-tuxcare.1, plus listed versions 2.5.5 |
2.5.5-tuxcare.1 |
org.webjars.npm:vuetifyMaven |
2.0.0-beta.4 up to 2.6.10, plus listed versions 2.0.02.0.0-beta.52.0.0-beta.62.0.0-beta.72.0.0-beta.8 Show 45 moreShow less2.0.0-beta.92.0.12.0.102.0.112.0.142.0.152.0.162.0.182.0.22.0.32.0.42.0.52.0.72.0.92.1.02.1.12.1.102.1.112.1.122.1.132.1.142.1.152.1.162.1.182.1.42.1.52.1.62.1.72.1.92.2.12.2.102.2.112.2.122.2.132.2.142.2.152.2.162.2.172.2.182.2.192.2.202.2.212.2.222.2.232.2.25 |
2.6.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-25873 is a medium vulnerability (CVSS 4.6) in Vuetifyjs Vuetify, published September 18, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in vuetify 2.6.10.
References
security.snyk.io/vuln/SNYK-JS-VUETIFY-3019858
security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-3024406
security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSBOWERGITHUBVUETIFYJS-3024407
github.com/vuetifyjs/vuetify/commit/ade1434927f55a0eccf3d54f900f24c5fa85a176
github.com/vuetifyjs/vuetify/issues/15757
codepen.io/5v3n-08/pen/MWGKEjY
Left out here: 70 versions. The JSON record has them.