Every CVE Search/ Get API key

CVE-2022-2589

Cross-site Scripting (XSS) - Reflected in beancount/fava

6.9 MediumFix available

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
High
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
High
Availability
None

Exploit likelihood

0.75%Down 0.1 points since Aug 2, 2022
90%50%10%1%

What each source reports

CVE List Score used 6.9

Cross-site Scripting (XSS) - Reflected in beancount/fava

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
CVE-2022-2589
CVSS 3.0
6.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-0102 6.9

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
EUVD-2022-0102
CVSS 3.0
6.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-6hcj-qrw3-m66q 5.3

Fava vulnerable to reflected cross-site scripting

Fava before 1.22.3 is vulnerable to reflected cross-site scripting due to improper validation on filter conversion.

Record
GHSA-6hcj-qrw3-m66q
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 6.1

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
CVE-2022-2589
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
6.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 6.9

Cross-site Scripting (XSS) - Reflected in beancount/fava

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
CVE-2022-2589
CVSS 3.0
6.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVDEBIAN-CVE-2022-2589 6.1

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
DEBIAN-CVE-2022-2589
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
OSVGHSA-6hcj-qrw3-m66q 5.3

Fava vulnerable to reflected cross-site scripting

Fava before 1.22.3 is vulnerable to reflected cross-site scripting due to improper validation on filter conversion.

Record
GHSA-6hcj-qrw3-m66q
CVSS 4.0
5.3 MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVUBUNTU-CVE-2022-2589 6.1

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
UBUNTU-CVE-2022-2589
CVSS 3.1
6.1 MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
6.9 MediumCVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N
Updated
2026-11-02
OSVPYSEC-2022-246 No score

Cross-site Scripting (XSS) - Reflected in GitHub repository beancount/fava prior to 1.22.3.

Record
PYSEC-2022-246
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
fava
PyPI
before 1.22.3
1.22.3
fava
Debian:11
All versions, plus listed versions
1.18-11.20.1-11.20.1-21.23.1+dfsg-11.23.1-11.30.2+dfsg-1
None known
fava
PyPI
before 1.22.3, plus listed versions
0.0.01.101.111.121.13
Show 19 moreShow less
1.141.151.161.171.181.191.201.20.11.211.221.22.11.22.21.31.41.51.61.71.81.9
1.22.3
fava
Ubuntu:20.04:LTS
All versions, plus listed versions
1.10-21.11-11.14-1
None known
fava
Ubuntu:22.04:LTS
All versions, plus listed versions
1.18-11.20.1-1
None known
fava
Ubuntu:25.10
All versions, plus listed versions
1.30.2+dfsg-1
None known
fava
Ubuntu:26.10
All versions, plus listed versions
1.30.2+dfsg-1
None known
fava
Ubuntu:26.04:LTS
All versions, plus listed versions
1.30.2+dfsg-1
None known

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-2589 is a medium vulnerability (CVSS 6.9) in Beancount Beancount/fava, published August 1, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.75%, the 55th percentile. Fixed in fava 1.22.3.

References

Show 4 moreShow less
MoveEnter Open