CVE-2022-25896
Session Fixation
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- High
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
4.8
Session Fixation
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
CVE-2022-25896- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - Updated
- 2026-11-02
EUVDEUVD-2022-6420
4.8
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
EUVD-2022-6420- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-v923-w3x8-wh69
4.8
Passport vulnerable to session regeneration when a users logs in or out
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
GHSA-v923-w3x8-wh69- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - Weakness
- CWE-384
- Updated
- 2026-11-02
NVD
4.8
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
CVE-2022-25896- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 2.0
- 5.8 Medium
AV:N/AC:M/Au:N/C:P/I:P/A:N - Weakness
- CWE-384
- Updated
- 2026-11-02
OSV
4.8
Session Fixation
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
CVE-2022-25896- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-25896
4.8
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
DEBIAN-CVE-2022-25896- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
Show 4 moreShow less
OSVGHSA-v923-w3x8-wh69
4.8
Passport vulnerable to session regeneration when a users logs in or out
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
GHSA-v923-w3x8-wh69- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - Weakness
- CWE-384
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-25896
4.8
This affects the package passport before 0.6.0. When a user logs in or logs out, the session is regenerated instead of being closed.
- Record
UBUNTU-CVE-2022-25896- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
OSVCLSA-2026-1774830278 No score
TuxCare security update for passport (1 CVE)
TuxCare rebuilt passport to address 1 CVE. Fixed in 0.5.3-tuxcare.1.
- Record
CLSA-2026-1774830278- Updated
- 2026-11-02
OSVROOT-APP-NPM-CVE-2022-25896 No score
CVE-2022-25896 in @rootio/passport - Patched by Root
Root has patched CVE-2022-25896 in the @rootio/passport package for Root:npm. Multiple fixed versions available.
- Record
ROOT-APP-NPM-CVE-2022-25896- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
passportnpm |
before 0.6.0 | 0.6.0 |
passportTuxCare:npm |
0.5.3-tuxcare.0 up to 0.5.3-tuxcare.1, plus listed versions 0.5.3 |
0.5.3-tuxcare.1 |
passportjsDebian:12 |
before 0.6.0+~1.0.0-1 | 0.6.0+~1.0.0-1 |
passportjsDebian:13 |
before 0.6.0+~1.0.0-1 | 0.6.0+~1.0.0-1 |
passportjsDebian:14 |
before 0.6.0+~1.0.0-1 | 0.6.0+~1.0.0-1 |
@rootio/passportRoot:npm |
before 0.5.3-root.io.1 | 0.5.3-root.io.1 |
passportRoot:npm |
before 0.5.3-aikido.1 | 0.5.3-aikido.1 |
passportjsUbuntu:16.04:LTS |
All versions, plus listed versions 0.1.17-1 |
None known |
passportjsUbuntu:18.04:LTS |
All versions, plus listed versions 0.1.17-1 |
None known |
passportjsUbuntu:20.04:LTS |
All versions, plus listed versions 0.1.17-1 |
None known |
passportjsUbuntu:22.04:LTS |
All versions, plus listed versions 0.4.1-10.5.0+~1.0.0-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases, products, published | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-25896 is a medium vulnerability (CVSS 4.8) in Laravel Passport, published July 1, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.12%, the 66th percentile. Fixed in passport 0.6.0.
References
snyk.io/vuln/SNYK-JS-PASSPORT-2840631
github.com/jaredhanson/passport/pull/900
github.com/jaredhanson/passport/commit/7e9b9cf4d7be02428e963fc729496a45baeea608
nvd.nist.gov/vuln/detail/CVE-2022-25896
github.com/advisories/GHSA-v923-w3x8-wh69
github.com/CVEProject/cvelistV5/tree/main/cves/2022/25xxx/CVE-2022-25896.json