Every CVE Search/ Get API key

CVE-2022-26291

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the...

5.5 MediumFix available

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

0.87%Unchanged since Mar 29, 2022
90%50%10%1%

What each source reports

NVD Score used 5.5

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
CVE-2022-26291
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
CVSS 2.0
4.3 MediumAV:N/AC:M/Au:N/C:N/I:N/A:P
Weakness
CWE-416
Updated
2026-11-02
CVE List No score

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
CVE-2022-26291
Updated
2026-11-02
EUVDEUVD-2022-30852 No score

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
EUVD-2022-30852
Updated
2026-11-03
GitHub AdvisoriesGHSA-65qg-fhgm-59fj 5.5

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the...

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
GHSA-65qg-fhgm-59fj
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Weakness
CWE-416
Updated
2026-11-02
OSVALPINE-CVE-2022-26291 5.5

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
ALPINE-CVE-2022-26291
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVDEBIAN-CVE-2022-26291 5.5

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
DEBIAN-CVE-2022-26291
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-26291 5.5

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
UBUNTU-CVE-2022-26291
CVSS 3.1
5.5 MediumCVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV No score

lrzip v0.641 was discovered to contain a multiple concurrency use-after-free between the functions zpaq_decompress_buf() and clear_rulist(). This vulnerability allows attackers to cause a Denial of Service (DoS) via a crafted Irz file.

Record
CVE-2022-26291
Updated
2026-11-02
OSVUSN-5840-1 No score

lrzip vulnerabilities

It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-25467)

It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2021-27345, CVE-2021-27347)

It was discovered that Long Range ZIP incorrectly handled pointers. If a user or an automated system were tricked into opening a certain specially crafted ZIP file, an attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2022-26291)

It was discovered that Long Range ZIP incorrectly handled memory allocation, which could lead to a heap memory corruption. An attacker could possibly use this issue to cause denial of service. This issue affected Ubuntu 14.04 ESM, Ubuntu 16.04 ESM, Ubuntu 18.04 LTS, Ubuntu 20.04 LTS, Ubuntu 22.04 LTS, and Ubuntu 22.10. (CVE-2022-28044)

Record
USN-5840-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lrzip
Alpine:v3.17
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.18
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.19
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.20
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.21
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.22
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.23
before 0.650-r0
0.650-r0
lrzip
Alpine:v3.24
before 0.650-r0
0.650-r0
lrzip
Debian:12
before 0.650-1
0.650-1
lrzip
Debian:13
before 0.650-1
0.650-1
Show 12 moreShow less
Affected packages
PackageAffectedFixed
lrzip
Debian:14
before 0.650-1
0.650-1
lrzip
Debian:9
From an advisory covering 5 CVEs
before 0.631-1+deb9u2, plus listed versions
0.631-10.631-1+deb9u1
0.631-1+deb9u2
lrzip
Debian:10
From an advisory covering 3 CVEs
before 0.631+git180528-1+deb10u1, plus listed versions
0.631+git180528-1
0.631+git180528-1+deb10u1
lrzip
Debian:11
From an advisory covering 3 CVEs
before 0.641-1+deb11u1, plus listed versions
0.641-1
0.641-1+deb11u1
lrzip
Ubuntu:Pro:16.04:LTS
before 0.621-1ubuntu0.1~esm2, plus listed versions
0.621-10.621-1ubuntu0.1~esm1
0.621-1ubuntu0.1~esm2
lrzip
Ubuntu:18.04:LTS
before 0.631-1+deb9u3build0.18.04.1, plus listed versions
0.631-10.631-1+deb9u1build0.18.04.1
0.631-1+deb9u3build0.18.04.1
lrzip
Ubuntu:20.04:LTS
before 0.631+git180528-1+deb10u1build0.20.04.1, plus listed versions
0.631+git180528-10.631+git180528-1build1
0.631+git180528-1+deb10u1build0.20.04.1
lrzip
Ubuntu:Pro:14.04:LTS
From an advisory covering 6 CVEs
before 0.616-1ubuntu0.1~esm2, plus listed versions
0.608-20.616-10.616-1ubuntu0.1~esm0.616-1ubuntu0.1~esm1
0.616-1ubuntu0.1~esm2
lrzip
Ubuntu:Pro:16.04:LTS
From an advisory covering 6 CVEs
before 0.621-1ubuntu0.1~esm2, plus listed versions
0.621-10.621-1ubuntu0.1~esm1
0.621-1ubuntu0.1~esm2
lrzip
Ubuntu:18.04:LTS
From an advisory covering 6 CVEs
before 0.631-1+deb9u3build0.18.04.1, plus listed versions
0.631-10.631-1+deb9u1build0.18.04.1
0.631-1+deb9u3build0.18.04.1
lrzip
Ubuntu:20.04:LTS
From an advisory covering 6 CVEs
before 0.631+git180528-1+deb10u1build0.20.04.1, plus listed versions
0.631+git180528-10.631+git180528-1build1
0.631+git180528-1+deb10u1build0.20.04.1
lrzip
Ubuntu:22.04:LTS
From an advisory covering 6 CVEs
before 0.651-2ubuntu0.22.04.1, plus listed versions
0.641-10.651-2
0.651-2ubuntu0.22.04.1

History

History
RecordedChangedSources
affected, factsOSV
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-26291 is a medium vulnerability (CVSS 5.5) in Debian Linux, published March 28, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 58th percentile. Fixed in lrzip 0.650-r0.

References

Show 10 moreShow less
MoveEnter Open