Every CVE Search/ Get API key

CVE-2022-2650

Improper Restriction of Excessive Authentication Attempts in wger-project/wger

7.8 HighFix available

CVE-2022-2650 is a high vulnerability (CVSS 7.8) in Wger, published November 24, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.74%, the 54th percentile. Fixed in wger 2.2.

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.74%Down 0.1 points since Nov 25, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.8

Improper Restriction of Excessive Authentication Attempts in wger-project/wger

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
CVE-2022-2650
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
EUVDEUVD-2022-7352 7.8

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
EUVD-2022-7352
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-gr58-76rp-mmg4 9.8

wger vulnerable to brute force attempts

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
GHSA-gr58-76rp-mmg4
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
NVD 9.8

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
CVE-2022-2650
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
OSV 7.8

Improper Restriction of Excessive Authentication Attempts in wger-project/wger

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
CVE-2022-2650
CVSS 3.0
7.8 HighCVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
OSVGHSA-gr58-76rp-mmg4 9.8

wger vulnerable to brute force attempts

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
GHSA-gr58-76rp-mmg4
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-307
Updated
2026-11-02
OSVPYSEC-2026-573 9.8

wger vulnerable to brute force attempts

Improper Restriction of Excessive Authentication Attempts in GitHub repository wger-project/wger prior to 2.2.

Record
PYSEC-2026-573
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
wger
PyPI
before 2.2
2.2
wger
PyPI
before 2.2, plus listed versions
1.11.1.11.21.2rc11.3
Show 9 moreShow less
1.41.51.61.6.11.71.81.92.02.1
2.2

History

History
WhenChangedSources
2026-11-02createdCVE List, EUVD, GitHub Advisories, NVD, OSV

References

MoveEnter Open