CVE-2022-26562
An issue in provider/libserver/ECKrbAuth.cpp of Kopano-Core v11.0.2.51 contains an issue which...
An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).
- Record
CVE-2022-26562- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-287
- Updated
- 2026-11-02
CVE List No score
An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).
- Record
CVE-2022-26562- Updated
- 2026-11-02
EUVDEUVD-2022-31118 No score
An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).
- Record
EUVD-2022-31118- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-24g4-fh3x-4f5h
9.8
An issue in provider/libserver/ECKrbAuth.cpp of Kopano-Core v11.0.2.51 contains an issue which...
An issue in provider/libserver/ECKrbAuth.cpp of Kopano-Core v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired.
- Record
GHSA-24g4-fh3x-4f5h- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-287
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-26562
9.8
An issue in provider/libserver/ECKrbAuth.cpp of Kopano Core <= v11.0.2.51 contains an issue which allows attackers to authenticate even if the user account or password is expired. It also exists in the predecessor Zarafa Collaboration Platform (ZCP) in provider/libserver/ECPamAuth.cpp of Zarafa >= 6.30 (introduced between 6.30.0 RC1e and 6.30.8 final).
- Record
UBUNTU-CVE-2022-26562- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUSN-6876-1 No score
kopanocore vulnerabilities
It was discovered that Kopano Core allowed out-of-bounds access. An attacker could use this issue to expose private information. This issue only affected Ubuntu 18.04 LTS. (CVE-2019-19907)
It was discovered that Kopano Core allowed possible authentication with expired passwords. An attacker could use this issue to bypass authentication. (CVE-2022-26562)
- Record
USN-6876-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
kopanocoreDebian:10 From an advisory covering 2 CVEs |
before 8.7.0-3+deb10u1, plus listed versions 8.7.0-3 |
8.7.0-3+deb10u1 |
kopanocoreUbuntu:Pro:18.04:LTS |
before 8.5.5-0ubuntu1+esm1, plus listed versions 8.1.0-3ubuntu58.1.0-3ubuntu68.3.4-4ubuntu48.5.2-1ubuntu18.5.5-0ubuntu1 |
8.5.5-0ubuntu1+esm1 |
kopanocoreUbuntu:20.04:LTS |
before 8.7.0-7ubuntu1.1, plus listed versions 8.7.0-3build28.7.0-5ubuntu58.7.0-5ubuntu68.7.0-6ubuntu18.7.0-6ubuntu28.7.0-6ubuntu38.7.0-7ubuntu1 |
8.7.0-7ubuntu1.1 |
kopanocoreUbuntu:22.04:LTS |
before 8.7.0-7.1ubuntu10.1, plus listed versions 8.7.0-7.1ubuntu48.7.0-7.1ubuntu68.7.0-7.1ubuntu78.7.0-7.1ubuntu88.7.0-7.1ubuntu10 |
8.7.0-7.1ubuntu10.1 |
kopanocoreUbuntu:Pro:18.04:LTS From an advisory covering 2 CVEs |
before 8.5.5-0ubuntu1+esm1, plus listed versions 8.1.0-3ubuntu58.1.0-3ubuntu68.3.4-4ubuntu48.5.2-1ubuntu18.5.5-0ubuntu1 |
8.5.5-0ubuntu1+esm1 |
kopanocoreUbuntu:20.04:LTS From an advisory covering 2 CVEs |
before 8.7.0-7ubuntu1.1, plus listed versions 8.7.0-3build28.7.0-5ubuntu58.7.0-5ubuntu68.7.0-6ubuntu18.7.0-6ubuntu28.7.0-6ubuntu38.7.0-7ubuntu1 |
8.7.0-7ubuntu1.1 |
kopanocoreUbuntu:22.04:LTS From an advisory covering 2 CVEs |
before 8.7.0-7.1ubuntu10.1, plus listed versions 8.7.0-7.1ubuntu48.7.0-7.1ubuntu68.7.0-7.1ubuntu78.7.0-7.1ubuntu88.7.0-7.1ubuntu10 |
8.7.0-7.1ubuntu10.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, facts | ||
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-26562 is a critical vulnerability (CVSS 9.8) in Kopano Groupware Core, published April 1, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.15%, the 82nd percentile. Fixed in kopanocore 8.5.5-0ubuntu1+esm1.
References
kopano.com
stash.kopano.io/projects/KC/repos/kopanocore/browse/provider/libserver/ECKrbAuth.cpp
lists.debian.org/debian-lts-announce/2023/03/msg00006.html
jira.kopano.io/browse/KC-2021
github.com/Kopano-dev/kopano-core/blob/master/provider/libserver/ECKrbAuth.cpp
bugzilla.redhat.com/show_bug.cgi?id=2192126
Show 8 moreShow less
bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-342b96903b
src.fedoraproject.org/rpms/zarafa/c/a5a8366ccf07f248fae6edffb5123cfda579bfdb?branch=epel7
nvd.nist.gov/vuln/detail/CVE-2022-26562
github.com/advisories/GHSA-24g4-fh3x-4f5h
ubuntu.com/security/CVE-2022-26562
cve.org/CVERecord?id=CVE-2022-26562
ubuntu.com/security/notices/USN-6876-1
ubuntu.com/security/CVE-2019-19907