CVE-2022-26846
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary...
CVE-2022-26846 is a high vulnerability (CVSS 8.8) in Spip, published March 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.98%, the 87th percentile. Fixed in spip 4.0.5-1.
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
8.8
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
CVE-2022-26846- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 6.5 Medium
AV:N/AC:L/Au:S/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
CVE-2022-26846- Updated
- 2026-11-02
EUVDEUVD-2022-31396 No score
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
EUVD-2022-31396- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-g92v-g454-76hx
8.8
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary...
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
GHSA-g92v-g454-76hx- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV
8.8
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
CVE-2022-26846- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-26846
8.8
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
UBUNTU-CVE-2022-26846- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-26846 No score
SPIP before 3.2.14 and 4.x before 4.0.5 allows remote authenticated editors to execute arbitrary code.
- Record
DEBIAN-CVE-2022-26846- Updated
- 2026-11-03
OSVUSN-5482-1 No score
spip vulnerabilities
It was discovered that SPIP incorrectly validated inputs. An authenticated attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 18.04 LTS. (CVE-2020-28984)
Charles Fol and Théo Gordyjan discovered that SPIP is vulnerable to Cross Site Scripting (XSS). If a user were tricked into browsing a malicious SVG file, an attacker could possibly exploit this issue to execute arbitrary code. This issue was only fixed in Ubuntu 21.10. (CVE-2021-44118, CVE-2021-44120, CVE-2021-44122, CVE-2021-44123)
It was discovered that SPIP incorrectly handled certain forms. A remote authenticated editor could possibly use this issue to execute arbitrary code, and a remote unauthenticated attacker could possibly use this issue to obtain sensitive information. (CVE-2022-26846, CVE-2022-26847)
- Record
USN-5482-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
spipDebian:13 |
before 4.0.5-1 | 4.0.5-1 |
spipDebian:14 |
before 4.0.5-1 | 4.0.5-1 |
spipDebian:9 |
before 3.1.4-4~deb9u5, plus listed versions 3.1.4-23.1.4-33.1.4-3~deb9u13.1.4-4~deb9u13.1.4-4~deb9u2 Show 4 moreShow less3.1.4-4~deb9u33.1.4-4~deb9u43.1.4-4~deb9u4+deb9u13.1.4-4~deb9u4+deb9u2 |
3.1.4-4~deb9u5 |
spipDebian:10 |
before 3.2.4-1+deb10u7, plus listed versions 3.2.4-13.2.4-1+deb10u13.2.4-1+deb10u23.2.4-1+deb10u33.2.4-1+deb10u43.2.4-1+deb10u53.2.4-1+deb10u6 |
3.2.4-1+deb10u7 |
spipDebian:11 |
before 3.2.11-3+deb11u3, plus listed versions 3.2.11-33.2.11-3+deb11u13.2.11-3+deb11u2 |
3.2.11-3+deb11u3 |
spipUbuntu:18.04:LTS |
before 3.1.4-4~deb9u5build0.18.04.1, plus listed versions 3.1.4-33.1.4-4~deb9u3build0.18.04.1 |
3.1.4-4~deb9u5build0.18.04.1 |
spipUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 3.2.4-13.2.5-13.2.7-13.2.7-1ubuntu0.13.2.7-1ubuntu0.1+esm2 |
None known |
spipUbuntu:22.04:LTS |
All versions, plus listed versions 3.2.11-33.2.12-14.0.2-14.0.4-1 |
None known |
History
| When | Changed | Sources |
|---|---|---|
| 2026-11-03 | aliases | EUVD |
| 2026-11-02 | created | CVE List, GitHub Advisories, NVD, OSV |
References
lists.debian.org/debian-security-announce/2022/msg00060.html
blog.spip.net/Mise-a-jour-critique-de-securite-sorties-de-SPIP-4-0-5-et-SPIP-3-2-14.html
git.spip.net/spip/medias/commit/3014b845da2dd8ad15ff04b50fd9dbba388a9ca2
lists.debian.org/debian-lts-announce/2022/03/msg00020.html
nvd.nist.gov/vuln/detail/CVE-2022-26846
github.com/advisories/GHSA-g92v-g454-76hx
Show 10 moreShow less
security-tracker.debian.org/tracker/CVE-2022-26846
ubuntu.com/security/CVE-2022-26846
ubuntu.com/security/notices/USN-5482-1
cve.org/CVERecord?id=CVE-2022-26846
ubuntu.com/security/CVE-2020-28984
ubuntu.com/security/CVE-2021-44118
ubuntu.com/security/CVE-2021-44120
ubuntu.com/security/CVE-2021-44122
ubuntu.com/security/CVE-2021-44123
ubuntu.com/security/CVE-2022-26847