CVE-2022-26874
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice...
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
CVE-2022-26874- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
CVE-2022-26874- Updated
- 2026-11-02
EUVDEUVD-2022-31423 No score
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
EUVD-2022-31423- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q622-5f2g-fmg6
5.4
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice...
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
GHSA-q622-5f2g-fmg6- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-26874
5.4
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
DEBIAN-CVE-2022-26874- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-26874
5.4
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
UBUNTU-CVE-2022-26874- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSV No score
lib/Horde/Mime/Viewer/Ooo.php in Horde Mime_Viewer before 2.2.4 allows XSS via an OpenOffice document, leading to account takeover in Horde Groupware Webmail Edition. This occurs after XSLT rendering.
- Record
CVE-2022-26874- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
php-horde-mime-viewerDebian:12 |
before 2.2.4+debian0-1, plus listed versions 1.0.8-11.0.8-1.12.0.1-12.0.1-22.0.2-1 Show 17 moreShow less2.0.4-12.0.5-12.0.6-12.0.7-12.0.7-22.1.0-12.1.1-12.1.1-22.1.2-12.1.2-22.1.3-12.1.3-22.2.1-12.2.2-12.2.2-22.2.2-32.2.2-4 |
2.2.4+debian0-1 |
php-horde-mime-viewerDebian:9 |
before 2.2.1-1+deb9u1, plus listed versions 2.2.1-1 |
2.2.1-1+deb9u1 |
php-horde-mime-viewerDebian:10 |
before 2.2.2-3+deb10u1, plus listed versions 2.2.2-3 |
2.2.2-3+deb10u1 |
php-horde-mime-viewerDebian:11 |
before 2.2.4+debian0-2~deb11u1 | 2.2.4+debian0-2~deb11u1 |
php-horde-mime-viewerUbuntu:16.04:LTS |
All versions, plus listed versions 2.1.1-12.1.1-22.1.2-12.1.2-1build1 |
None known |
php-horde-mime-viewerUbuntu:18.04:LTS |
All versions, plus listed versions 2.2.1-12.2.2-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-26874 is a medium vulnerability (CVSS 5.4) in Debian Linux, published March 11, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.05%, the 64th percentile. Fixed in php-horde-mime-viewer 2.2.4+debian0-1.
References
blog.sonarsource.com/horde-webmail-account-takeover-via-email
github.com/horde/Mime_Viewer/commit/02b46cec1a7e8f1a6835b628850cd56b85963bb5
lists.debian.org/debian-lts-announce/2022/06/msg00007.html
lists.debian.org/debian-lts-announce/2022/08/msg00021.html
lists.debian.org/debian-lts-announce/2024/10/msg00015.html
nvd.nist.gov/vuln/detail/CVE-2022-26874