CVE-2022-26884
Apache DolphinScheduler exposes files without authentication
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.5
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26884- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
CVE List
6.5
Apache DolphinScheduler exposes files without authentication
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26884- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2022-7169
6.5
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
EUVD-2022-7169- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vpgf-fgm8-gxr2
6.5
Apache DolphinScheduler vulnerable to Path Traversal
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
GHSA-vpgf-fgm8-gxr2- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSV
6.5
Apache DolphinScheduler exposes files without authentication
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26884- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
OSVGHSA-vpgf-fgm8-gxr2
6.5
Apache DolphinScheduler vulnerable to Path Traversal
Users can read any files by log server, Apache DolphinScheduler users should upgrade to version 2.0.6 or higher.
- Record
GHSA-vpgf-fgm8-gxr2- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.dolphinscheduler:dolphinschedulerMaven |
before 2.0.6 | 2.0.6 |
org.apache.dolphinscheduler:dolphinschedulerMaven |
before 2.0.6, plus listed versions 1.2.01.2.11.3.01.3.11.3.2 Show 14 moreShow less1.3.31.3.41.3.51.3.61.3.71.3.81.3.92.0.02.0.0-alpha2.0.12.0.22.0.32.0.42.0.5 |
2.0.6 |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | shoucheng3/apache__dolphinscheduler_CVE-2022-26884_2-0-5 | 2025-08-16 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-26884 is a medium vulnerability (CVSS 6.5) in Apache Dolphinscheduler, published October 28, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 1.82%, the 78th percentile. Fixed in org.apache.dolphinscheduler:dolphinscheduler 2.0.6.
References
lists.apache.org/thread/xfdst5y4hnrm2ntmc5jzrgmw2htyyb9c
openwall.com/lists/oss-security/2022/10/28/2
nvd.nist.gov/vuln/detail/CVE-2022-26884
github.com/apache/dolphinscheduler/releases/tag/2.0.6
github.com/advisories/GHSA-vpgf-fgm8-gxr2
github.com/CVEProject/cvelistV5/tree/main/cves/2022/26xxx/CVE-2022-26884.json
github.com/apache/dolphinscheduler