CVE-2022-26885
Apache DolphinScheduler config file read by task risk
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26885- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
CVE List
7.5
Apache DolphinScheduler config file read by task risk
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26885- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2022-7378
7.5
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
EUVD-2022-7378- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-jvc3-wjf6-7c6c
7.5
Apache Dolphin Scheduler has insufficiently protected credentials
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
GHSA-jvc3-wjf6-7c6c- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-522
- Updated
- 2026-11-02
OSV
7.5
Apache DolphinScheduler config file read by task risk
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
CVE-2022-26885- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVGHSA-jvc3-wjf6-7c6c
7.5
Apache Dolphin Scheduler has insufficiently protected credentials
When using tasks to read config files, there is a risk of database password disclosure. We recommend you upgrade to version 2.0.6 or higher.
- Record
GHSA-jvc3-wjf6-7c6c- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-522
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler-commonMaven |
before 2.0.6 | 2.0.6 |
org.apache.dolphinscheduler:dolphinscheduler-commonMaven |
before 2.0.6, plus listed versions 1.2.01.2.11.3.01.3.11.3.2 Show 14 moreShow less1.3.31.3.41.3.51.3.61.3.71.3.81.3.92.0.02.0.0-alpha2.0.12.0.22.0.32.0.42.0.5 |
2.0.6 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-26885 is a high vulnerability (CVSS 7.5) in Apache Dolphinscheduler, published November 24, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.36%, the 71st percentile. Fixed in org.apache.dolphinscheduler:dolphinscheduler-common 2.0.6.
References
lists.apache.org/thread/z7084r9cs2r26cszkkgjqpb5bhnxqssp
nvd.nist.gov/vuln/detail/CVE-2022-26885
github.com/apache/dolphinscheduler/releases/tag/2.0.6
github.com/advisories/GHSA-jvc3-wjf6-7c6c
github.com/CVEProject/cvelistV5/tree/main/cves/2022/26xxx/CVE-2022-26885.json
github.com/apache/dolphinscheduler