CVE-2022-2713
Insufficient Session Expiration in cockpit-hq/cockpit
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- High
- Availability
- Low
Exploit likelihood
What each source reports
CVE List Score used
8.6
Insufficient Session Expiration in cockpit-hq/cockpit
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
- Record
CVE-2022-2713- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
EUVDEUVD-2022-6633
8.6
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
- Record
EUVD-2022-6633- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-vm6p-35rw-3fxc
9.8
Cockpit before 2.2.0 vulnerable to Insufficient Session Expiration
Cockpit before version 2.2.0 is vulnerable to Insufficient Session Expiration. The application does not validate requests after password changes, allowing a user to change their account details even after an admin changes their password.
- Record
GHSA-vm6p-35rw-3fxc- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
NVD
9.8
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
- Record
CVE-2022-2713- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
8.6
Insufficient Session Expiration in cockpit-hq/cockpit
Insufficient Session Expiration in GitHub repository cockpit-hq/cockpit prior to 2.2.0.
- Record
CVE-2022-2713- CVSS 3.0
- 8.6 High
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:L - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGHSA-vm6p-35rw-3fxc
9.8
Cockpit before 2.2.0 vulnerable to Insufficient Session Expiration
Cockpit before version 2.2.0 is vulnerable to Insufficient Session Expiration. The application does not validate requests after password changes, allowing a user to change their account details even after an admin changes their password.
- Record
GHSA-vm6p-35rw-3fxc- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-613
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
aheinze/cockpitPackagist |
before 2.2.0 | 2.2.0 |
aheinze/cockpitPackagist |
before 2.2.0, plus listed versions 0.10.00.10.10.10.20.11.00.11.1 Show 25 moreShow less0.11.20.12.00.12.10.12.20.6.00.6.10.6.20.7.00.7.10.7.20.8.00.8.10.8.100.8.110.8.20.8.30.8.40.8.60.8.70.8.80.8.90.9.00.9.10.9.20.9.3 |
2.2.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-2713 is a high vulnerability (CVSS 8.6) in Agentejo Cockpit, published August 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.25%, the 69th percentile. Fixed in aheinze/cockpit 2.2.0.
References
huntr.dev/bounties/3080fc96-75d7-4868-84de-9fc8c9b90290
github.com/cockpit-hq/cockpit/commit/dd8d0314912fa6517ebd2cc9939d9fafbe68731b
nvd.nist.gov/vuln/detail/CVE-2022-2713
github.com/advisories/GHSA-vm6p-35rw-3fxc
github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2713.json
github.com/cockpit-hq/cockpit