CVE-2022-2815
Insecure Storage of Sensitive Information in publify/publify
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.6
Insecure Storage of Sensitive Information in publify/publify
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-2815- CVSS 3.0
- 4.6 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-922
- Updated
- 2026-11-02
EUVDEUVD-2023-0379
4.6
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
EUVD-2023-0379- CVSS 3.0
- 4.6 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-79wq-g4v9-gfj4
6.5
Publify Core does not strip metadata from images
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-79wq-g4v9-gfj4- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-922
- Updated
- 2026-11-02
NVD
6.5
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-2815- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - CVSS 3.0
- 4.6 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-922
- Updated
- 2026-11-02
OSV
4.6
Insecure Storage of Sensitive Information in publify/publify
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
CVE-2022-2815- CVSS 3.0
- 4.6 Medium
CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N - Weakness
- CWE-922
- Updated
- 2026-11-02
OSVGHSA-79wq-g4v9-gfj4
6.5
Publify Core does not strip metadata from images
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
GHSA-79wq-g4v9-gfj4- CVSS 3.1
- 6.5 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-922
- Updated
- 2026-11-02
OSVBIT-publify-2022-2815 No score
Insecure Storage of Sensitive Information in GitHub repository publify/publify prior to 9.2.10.
- Record
BIT-publify-2022-2815- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
publify_coreRubyGems |
before 9.2.10 | 9.2.10 |
publifyBitnami |
before 9.2.10 | 9.2.10 |
publify_coreRubyGems |
before 9.2.10, plus listed versions 9.0.09.0.0.pre19.0.0.pre29.0.0.pre39.0.0.pre4 Show 14 moreShow less9.0.0.pre59.0.0.pre69.0.19.1.09.2.09.2.19.2.29.2.39.2.49.2.59.2.69.2.79.2.89.2.9 |
9.2.10 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-2815 is a medium vulnerability (CVSS 4.6) in Publify Publify/publify, published January 14, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.58%, the 47th percentile. Fixed in publify_core 9.2.10.
References
huntr.dev/bounties/22fdcc39-8c1a-4e4c-8eae-be3fd764f8b4
github.com/publify/publify/commit/af69097d349f4c00f244c51cd3c3e937fd3387cd
nvd.nist.gov/vuln/detail/CVE-2022-2815
github.com/publify/publify_core/commit/33f897c12b6efdcdfd8cf9df924deba0f878b71e
github.com/rubysec/ruby-advisory-db/blob/master/gems/publify_core/CVE-2022-2815.yml
github.com/advisories/GHSA-79wq-g4v9-gfj4
github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2815.json
github.com/publify/publify