Every CVE Search/ Get API key

CVE-2022-2831

A loaded (and valid) image can be crafted such that an out-of-bounds read or write occurs when...

7.5 HighFix available

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.61%Up 0.7 points since Aug 17, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
CVE-2022-2831
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-190, CWE-125, CWE-787
Updated
2026-11-02
CVE List No score

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
CVE-2022-2831
Weakness
CWE-190
Updated
2026-11-02
EUVDEUVD-2022-35067 No score

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
EUVD-2022-35067
Updated
2026-11-03
GitHub AdvisoriesGHSA-96cr-xqmm-9cj3 7.5

A loaded (and valid) image can be crafted such that an out-of-bounds read or write occurs when...

A loaded (and valid) image can be crafted such that an out-of-bounds read or write occurs when the image converted to thumbnail that is flipped vertically. Crash occured in source/blender/blendthumb/src/blendthumb_extract.cc

Record
GHSA-96cr-xqmm-9cj3
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVALPINE-CVE-2022-2831 7.5

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
ALPINE-CVE-2022-2831
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSV 7.5

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
CVE-2022-2831
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVDEBIAN-CVE-2022-2831 7.5

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
DEBIAN-CVE-2022-2831
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-2831 7.5

A flaw was found in Blender 3.3.0. An interger overflow in source/blender/blendthumb/src/blendthumb_extract.cc may lead to program crash or memory corruption.

Record
UBUNTU-CVE-2022-2831
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
blender
Alpine:v3.17
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.18
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.19
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.20
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.21
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.22
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.23
before 3.3.0-r0
3.3.0-r0
blender
Alpine:v3.24
before 3.3.0-r0
3.3.0-r0
blender
Debian:12
before 3.2.2+dfsg-1
3.2.2+dfsg-1
blender
Debian:13
before 3.2.2+dfsg-1
3.2.2+dfsg-1
Show 8 moreShow less
Affected packages
PackageAffectedFixed
blender
Ubuntu:16.04:LTS
All versions, plus listed versions
2.74+dfsg0-4build22.75.a+dfsg0-2ubuntu22.75.a+dfsg0-2ubuntu32.76.b+dfsg0-32.76.b+dfsg0-3build1
None known
blender
Ubuntu:18.04:LTS
All versions, plus listed versions
2.78.c+dfsg0-2build12.79+dfsg0-2build12.79+dfsg0-32.79+dfsg0-3build12.79.b+dfsg0-12.79.b+dfsg0-1ubuntu1.18.04.1
None known
blender
Ubuntu:20.04:LTS
All versions, plus listed versions
2.80+dfsg-32.80+dfsg-3build12.80+dfsg-42.81.a+dfsg-5build32.82+dfsg-12.82+dfsg-1build12.82.a+dfsg-1
None known
blender
Ubuntu:22.04:LTS
All versions, plus listed versions
2.93.3+dfsg-32.93.5+dfsg-12.93.5+dfsg-1build13.0.1+dfsg-7
None known
blender
Ubuntu:24.04:LTS
All versions, plus listed versions
3.6.2+dfsg-2ubuntu13.6.2+dfsg-2ubuntu24.0.2+dfsg-1ubuntu14.0.2+dfsg-1ubuntu24.0.2+dfsg-1ubuntu44.0.2+dfsg-1ubuntu64.0.2+dfsg-1ubuntu74.0.2+dfsg-1ubuntu8
None known
blender
Ubuntu:25.10
All versions, plus listed versions
4.3.2+dfsg-24.3.2+dfsg-2ubuntu14.3.2+dfsg-2ubuntu2
None known
blender
Ubuntu:26.10
All versions, plus listed versions
5.0.1+dfsg-1ubuntu15.0.1+dfsg-1ubuntu35.0.1+dfsg-3build15.0.1+dfsg-5
None known
blender
Ubuntu:26.04:LTS
All versions, plus listed versions
4.3.2+dfsg-2ubuntu25.0.1+dfsg-1ubuntu1
None known

History

History
RecordedChangedSources
affected, aliases, referencesOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-2831 is a high vulnerability (CVSS 7.5) in Blender, published August 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.61%, the 76th percentile. Fixed in blender 3.3.0-r0.

References

MoveEnter Open