CVE-2022-28352
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify...
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.3
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
CVE-2022-28352- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AC:L/AV:N/A:N/C:L/I:N/PR:N/S:U/UI:R - Updated
- 2026-11-02
EUVDEUVD-2022-32802
4.3
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
EUVD-2022-32802- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AC:L/AV:N/A:N/C:L/I:N/PR:N/S:U/UI:R - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-q6x4-wf9q-6g23
4.8
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify...
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
GHSA-q6x4-wf9q-6g23- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
NVD
4.3
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
CVE-2022-28352- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - CVSS 2.0
- 4.0 Medium
AV:N/AC:H/Au:N/C:P/I:P/A:N - Weakness
- CWE-295
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-28352
4.8
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
ALPINE-CVE-2022-28352- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
OSV
4.3
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
CVE-2022-28352- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AC:L/AV:N/A:N/C:L/I:N/PR:N/S:U/UI:R - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-28352
4.8
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
DEBIAN-CVE-2022-28352- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-28352
4.3
WeeChat (aka Wee Enhanced Environment for Chat) 3.2 to 3.4 before 3.4.1 does not properly verify the TLS certificate of the server, after certain GnuTLS options are changed, which allows man-in-the-middle attackers to spoof a TLS chat server via an arbitrary certificate. NOTE: this only affects situations where weechat.network.gnutls_ca_system or weechat.network.gnutls_ca_user is changed without a WeeChat restart.
- Record
UBUNTU-CVE-2022-28352- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N - CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
weechatAlpine:v3.15 |
3.2 up to 3.5-r0 | 3.5-r0 |
weechatDebian:12 |
before 3.4.1-1 | 3.4.1-1 |
weechatDebian:13 |
before 3.4.1-1 | 3.4.1-1 |
weechatDebian:14 |
before 3.4.1-1 | 3.4.1-1 |
weechatUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1.3-11.3-1build11.4-11.4-1build11.4-1build21.4-21.4-2ubuntu0.11.4-2ubuntu0.1+esm1 |
None known |
weechatUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1.9.1-11.9.1-1build11.9.1-1ubuntu11.9.1-1ubuntu1+esm1 |
None known |
weechatUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 2.6-22.6-2build12.6-2build22.6-2ubuntu12.6-2ubuntu22.8-12.8-1ubuntu0.1~esm1 |
None known |
weechatUbuntu:22.04:LTS |
All versions, plus listed versions 3.3-13.3-1ubuntu13.4-23.4-2build13.4-2build23.4.1-13.5-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28352 is a medium vulnerability (CVSS 4.3) in Weechat, published April 2, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.43%, the 37th percentile. Fixed in weechat 3.5-r0.
References
weechat.org/doc/security/WSA-2022-1
github.com/weechat/weechat/issues/1763
nvd.nist.gov/vuln/detail/CVE-2022-28352
github.com/advisories/GHSA-q6x4-wf9q-6g23
security.alpinelinux.org/vuln/CVE-2022-28352
github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28352.json
security-tracker.debian.org/tracker/CVE-2022-28352
ubuntu.com/security/CVE-2022-28352
cve.org/CVERecord?id=CVE-2022-28352