CVE-2022-28550
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c,...
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
CVE-2022-28550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787, CWE-120
- Updated
- 2026-11-02
CVE List
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
CVE-2022-28550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-787, CWE-120
- Updated
- 2026-11-02
EUVDEUVD-2022-32992
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
EUVD-2022-32992- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-phqx-gjxc-wrp9
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c,...
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
GHSA-phqx-gjxc-wrp9- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-120, CWE-787
- Updated
- 2026-11-02
OSV
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
CVE-2022-28550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-28550
9.8
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
UBUNTU-CVE-2022-28550- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-28550 No score
Matthias-Wandel/jhead jhead 3.06 is vulnerable to Buffer Overflow via shellescape(), jhead.c, jhead. jhead copies strings to a stack buffer when it detects a &i or &o. However, jhead does not check the boundary of the stack buffer. As a result, there will be a stack buffer overflow problem when multiple &i or &o are given.
- Record
DEBIAN-CVE-2022-28550- Updated
- 2026-11-03
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jheadDebian:12 |
All versions, plus listed versions 1:3.06.0.1-61:3.08-11:3.08-21:3.08-3 |
None known |
jheadDebian:13 |
before 1:3.08-1 | 1:3.08-1 |
jheadDebian:14 |
before 1:3.08-1 | 1:3.08-1 |
jheadUbuntu:Pro:14.04:LTS |
All versions, plus listed versions 1:2.97-11:2.97-1+deb8u1build0.14.04.11:2.97-1+deb8u2build0.14.04.1~esm11:2.97-1+deb8u2ubuntu0.1~esm11:2.97-1+deb8u2ubuntu0.1~esm21:2.97-1+deb8u2ubuntu0.1~esm31:2.97-1+deb8u2ubuntu0.1~esm4 |
None known |
jheadUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 1:3.00-11:3.00-21:3.00-31:3.00-4+deb9u1build0.16.04.11:3.00-4+deb9u1ubuntu0.1~esm11:3.00-4+deb9u1ubuntu0.1~esm21:3.00-4+deb9u1ubuntu0.1~esm31:3.00-4+deb9u1ubuntu0.1~esm4 |
None known |
jheadUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 1:3.00-41:3.00-51:3.00-61:3.00-8~build0.18.04.11:3.00-8~ubuntu0.11:3.00-8~ubuntu0.21:3.00-8~ubuntu0.2+esm1 |
None known |
jheadUbuntu:Pro:20.04:LTS |
All versions, plus listed versions 1:3.03-31:3.04-11:3.04-1ubuntu0.11:3.04-1ubuntu0.21:3.04-1ubuntu0.2+esm1 |
None known |
jheadUbuntu:Pro:22.04:LTS |
All versions, plus listed versions 1:3.04-61:3.06.0.1-21:3.06.0.1-2ubuntu0.22.04.11:3.06.0.1-2ubuntu0.22.04.1+esm1 |
None known |
jheadUbuntu:24.04:LTS |
All versions, plus listed versions 1:3.08-11:3.08-2 |
None known |
jheadUbuntu:25.10 |
All versions, plus listed versions 1:3.08-3 |
None known |
jheadUbuntu:26.10 |
All versions, plus listed versions 1:3.08-3build1 |
None known |
jheadUbuntu:26.04:LTS |
All versions, plus listed versions 1:3.08-31:3.08-3build1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28550 is a critical vulnerability (CVSS 9.8) in Jhead Project Jhead, published June 13, 2023. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.05%, the 64th percentile. Fixed in jhead 1:3.08-1.
References
github.com/Matthias-Wandel/jhead/issues/51
github.com/Matthias-Wandel/jhead/commit/64894dbc7d8e1e232e85f1cab25c64290b2fc167
nvd.nist.gov/vuln/detail/CVE-2022-28550
github.com/advisories/GHSA-phqx-gjxc-wrp9
github.com/CVEProject/cvelistV5/tree/main/cves/2022/28xxx/CVE-2022-28550.json
security-tracker.debian.org/tracker/CVE-2022-28550
ubuntu.com/security/CVE-2022-28550
cve.org/CVERecord?id=CVE-2022-28550