CVE-2022-2888
Insufficient Session Expiration in octoprint/octoprint
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.4
Insufficient Session Expiration in octoprint/octoprint
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
- Record
CVE-2022-2888- CVSS 3.0
- 4.4 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
EUVDEUVD-2022-0174
4.4
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
- Record
EUVD-2022-0174- CVSS 3.0
- 4.4 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-937f-qh3w-6g87
5.3
OctoPrint vulnerable to Insufficient Session Expiration.
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists. This issue is fixed in version 1.8.3.
- Record
GHSA-937f-qh3w-6g87- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 4.4 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
NVD
4.4
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
- Record
CVE-2022-2888- CVSS 3.1
- 4.4 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - CVSS 3.0
- 4.4 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
OSV
4.4
Insufficient Session Expiration in octoprint/octoprint
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
- Record
CVE-2022-2888- CVSS 3.0
- 4.4 Medium
CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVGHSA-937f-qh3w-6g87
5.3
OctoPrint vulnerable to Insufficient Session Expiration.
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists. This issue is fixed in version 1.8.3.
- Record
GHSA-937f-qh3w-6g87- CVSS 4.0
- 5.3 Medium
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N - CVSS 3.1
- 4.4 Medium
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N - Weakness
- CWE-613
- Updated
- 2026-11-02
OSVPYSEC-2022-282 No score
If an attacker comes into the possession of a victim's OctoPrint session cookie through whatever means, the attacker can use this cookie to authenticate as long as the victim's account exists.
- Record
PYSEC-2022-282- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
octoprintPyPI |
before 1.8.3 | 1.8.3 |
octoprintPyPI |
before 1.8.3, plus listed versions 1.3.111.3.121.3.12rc11.3.12rc31.4.0 Show 39 moreShow less1.4.0rc11.4.0rc21.4.0rc31.4.0rc41.4.0rc51.4.0rc61.4.11.4.1rc11.4.1rc21.4.1rc31.4.1rc41.4.21.5.01.5.0rc11.5.0rc21.5.0rc31.5.11.5.21.5.31.6.01.6.0rc11.6.0rc21.6.0rc31.6.11.7.01.7.0rc11.7.0rc21.7.0rc31.7.11.7.21.7.31.8.01.8.0rc11.8.0rc21.8.0rc31.8.0rc41.8.0rc51.8.11.8.2 |
1.8.3 |
octoprintPyPI |
before 1.8.3, plus listed versions 1.3.111.3.121.3.12rc11.3.12rc31.4.0 Show 45 moreShow less1.4.0rc11.4.0rc21.4.0rc31.4.0rc41.4.0rc51.4.0rc61.4.11.4.1rc11.4.1rc21.4.1rc31.4.1rc41.4.21.5.01.5.0rc11.5.0rc21.5.0rc31.5.11.5.21.5.31.6.01.6.0rc11.6.0rc21.6.0rc31.6.11.7.01.7.0rc11.7.0rc21.7.0rc31.7.11.7.21.7.31.8.01.8.0rc11.8.0rc21.8.0rc31.8.0rc41.8.0rc51.8.11.8.21.2.181.2.18rc11.2.17rc31.2.17rc21.2.17rc11.2.16 |
1.8.3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-2888 is a medium vulnerability (CVSS 4.4) in Octoprint, published September 21, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.29%, the 22nd percentile. Fixed in octoprint 1.8.3.
References
huntr.dev/bounties/d27d232b-2578-4b32-b3b4-74aabdadf629
github.com/octoprint/octoprint/commit/40e6217ac1a85cc5ed592873ae49db01d3005da4
nvd.nist.gov/vuln/detail/CVE-2022-2888
github.com/pypa/advisory-database/tree/main/vulns/octoprint/PYSEC-2022-282.yaml
github.com/advisories/GHSA-937f-qh3w-6g87
github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2888.json
github.com/octoprint/octoprint
Left out here: 23 versions. The JSON record has them.