CVE-2022-28889
Clickjacking in the web console
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
CVE-2022-28889- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-1021
- Updated
- 2026-11-02
CVE List No score
Clickjacking in the web console
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
CVE-2022-28889- Weakness
- CWE-1021
- Updated
- 2026-11-02
EUVDEUVD-2022-6386 No score
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
EUVD-2022-6386- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pgq7-jcj5-xx6h
4.3
Apache Druid before 0.23.0 vulnerable to clickjacking
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
GHSA-pgq7-jcj5-xx6h- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-1021
- Updated
- 2026-11-02
OSVGHSA-pgq7-jcj5-xx6h
4.3
Apache Druid before 0.23.0 vulnerable to clickjacking
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
GHSA-pgq7-jcj5-xx6h- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-1021
- Updated
- 2026-11-02
OSV No score
Clickjacking in the web console
In Apache Druid 0.22.1 and earlier, the server did not set appropriate headers to prevent clickjacking. Druid 0.23.0 and later prevent clickjacking using the Content-Security-Policy header.
- Record
CVE-2022-28889- Weakness
- CWE-1021
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.apache.druid:druidMaven |
before 0.23.0 | 0.23.0 |
org.apache.druid:druidMaven |
before 0.23.0, plus listed versions 0.13.0-incubating0.14.0-incubating0.14.1-incubating0.14.2-incubating0.15.0-incubating Show 15 moreShow less0.15.1-incubating0.16.0-incubating0.16.1-incubating0.17.00.17.10.18.00.18.10.19.00.20.00.20.10.20.20.21.00.21.10.22.00.22.1 |
0.23.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-28889 is a medium vulnerability (CVSS 4.3) in Apache Druid, published July 7, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.92%, the 80th percentile. Fixed in org.apache.druid:druid 0.23.0.