CVE-2022-29023
A buffer overflow in the razermouse driver of OpenRazer v3.3.0 and below allows attackers to...
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.8
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
CVE-2022-29023- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 7.5 High
AV:N/AC:L/Au:N/C:P/I:P/A:P - Weakness
- CWE-120
- Updated
- 2026-11-02
CVE List No score
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
CVE-2022-29023- Updated
- 2026-11-02
EUVDEUVD-2022-33453 No score
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
EUVD-2022-33453- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-h76w-xp2h-9r2m
7.5
A buffer overflow in the razermouse driver of OpenRazer v3.3.0 and below allows attackers to...
A buffer overflow in the razermouse driver of OpenRazer v3.3.0 and below allows attackers to cause a Denial of Service (DoS) via a crafted buffer sent to the matrix_custom_frame device.
- Record
GHSA-h76w-xp2h-9r2m- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H - Weakness
- CWE-120
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-29023
9.8
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
ALPINE-CVE-2022-29023- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVDEBIAN-CVE-2022-29023
9.8
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
DEBIAN-CVE-2022-29023- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-29023
9.8
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
UBUNTU-CVE-2022-29023- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSV No score
A buffer overflow vulnerability exists in the razermouse driver of OpenRazer up to version v3.3.0 allows attackers to cause a Denial of Service (DoS) and possibly escalate their privileges via a crafted buffer sent to the matrix_custom_frame device.
- Record
CVE-2022-29023- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
openrazerAlpine:v3.18 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.19 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.20 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.21 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.22 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.23 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerAlpine:v3.24 |
before 3.4.0-r0 | 3.4.0-r0 |
openrazerDebian:12 |
before 3.3.0+dfsg-1 | 3.3.0+dfsg-1 |
openrazerDebian:13 |
before 3.3.0+dfsg-1 | 3.3.0+dfsg-1 |
openrazerDebian:14 |
before 3.3.0+dfsg-1 | 3.3.0+dfsg-1 |
openrazerDebian:11 |
before 2.9.0+dfsg-1+deb11u1, plus listed versions 2.9.0+dfsg-1 |
2.9.0+dfsg-1+deb11u1 |
openrazerUbuntu:20.04:LTS |
All versions, plus listed versions 2.5.0+dfsg-1ubuntu2 |
None known |
openrazerUbuntu:22.04:LTS |
All versions, plus listed versions 2.9.0+dfsg-1ubuntu13.2.0+dfsg-3 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-29023 is a critical vulnerability (CVSS 9.8) in Openrazer Project Openrazer, published May 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.38%, the 83rd percentile. Fixed in openrazer 3.4.0-r0.