CVE-2022-29048
CSRF vulnerability in Jenkins Subversion Plugin
A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- None
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
4.3
A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.
- Record
CVE-2022-29048- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
CVE List No score
A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.
- Record
CVE-2022-29048- Updated
- 2026-11-02
EUVDEUVD-2022-1780 No score
A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.
- Record
EUVD-2022-1780- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m5cw-c64p-77h6
4.3
CSRF vulnerability in Jenkins Subversion Plugin
Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to connect to an attacker-specified URL.
- Record
GHSA-m5cw-c64p-77h6- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
OSV
4.3
A cross-site request forgery (CSRF) vulnerability in Jenkins Subversion Plugin 2.15.3 and earlier allows attackers to connect to an attacker-specified URL.
- Record
CVE-2022-29048- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-m5cw-c64p-77h6
4.3
CSRF vulnerability in Jenkins Subversion Plugin
Subversion Plugin 2.15.3 and earlier does not require POST requests for several form validation methods, resulting in cross-site request forgery (CSRF) vulnerabilities.
These vulnerabilities allow attackers to connect to an attacker-specified URL.
- Record
GHSA-m5cw-c64p-77h6- CVSS 3.1
- 4.3 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N - Weakness
- CWE-352
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:subversionMaven |
before 2.15.4 | 2.15.4 |
org.jenkins-ci.plugins:subversionMaven |
before 2.15.4, plus listed versions 1.241.251.261.281.29 Show 45 moreShow less1.301.311.321.331.341.351.361.371.381.391.401.411.421.431.441.451.481.501.511.531.542.02.0-alpha-12.0-beta-12.12.102.10.12.10.22.10.32.10.42.10.52.10.62.11.02.11.12.12.02.12.12.12.22.13.02.13.12.13.22.14.02.14.12.14.22.14.32.14.4 |
2.15.4 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-29048 is a medium vulnerability (CVSS 4.3) in Jenkins Subversion, published April 12, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.88%, the 79th percentile. Fixed in org.jenkins-ci.plugins:subversion 2.15.4.
References
jenkins.io/security/advisory/2022-04-12
support.apple.com/kb/HT213345
seclists.org/fulldisclosure/2022/Jul/18
nvd.nist.gov/vuln/detail/CVE-2022-29048
github.com/jenkinsci/subversion-plugin/commit/882a7d359f6ac73c53d787bff4d62eba837001ea
github.com/advisories/GHSA-m5cw-c64p-77h6
github.com/jenkinsci/subversion-plugin
Left out here: 31 versions. The JSON record has them.