Every CVE Search/ Get API key

CVE-2022-29266

apisix/jwt-auth may leak secrets in error response

7.5 HighFix available

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
None

Exploit likelihood

8.14%Up 7.3 points since Apr 20, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Record
CVE-2022-29266
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:P/I:N/A:N
Weakness
CWE-209
Updated
2026-11-02
CVE List No score

apisix/jwt-auth may leak secrets in error response

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Record
CVE-2022-29266
Weakness
CWE-209
Updated
2026-11-02
EUVDEUVD-2022-33609 No score

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Record
EUVD-2022-33609
Updated
2026-11-03
GitHub AdvisoriesGHSA-x46m-gg6j-22gf 7.5

In APache APISIX before 3.13.1, an attacker can obtain a plugin-configured secret via an error...

In APache APISIX before 3.13.1, an attacker can obtain a plugin-configured secret via an error message response by sending an incorrect JSON Web Token to a route protected by the jwt-auth plugin. The error logic in the dependency library lua-resty-jwt enables sending an RS256 token to an endpoint that requires an HS256 token, with the original secret value included in the error response.

Record
GHSA-x46m-gg6j-22gf
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weakness
CWE-209
Updated
2026-11-02
OSVBIT-apisix-2022-29266 No score

apisix/jwt-auth may leak secrets in error response

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Record
BIT-apisix-2022-29266
Updated
2026-11-02
OSV No score

apisix/jwt-auth may leak secrets in error response

In APache APISIX before 3.13.1, the jwt-auth plugin has a security issue that leaks the user's secret key because the error message returned from the dependency lua-resty-jwt contains sensitive information.

Record
CVE-2022-29266
Weakness
CWE-209
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
apisix
Bitnami
before 2.13.1
2.13.1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-29266 is a high vulnerability (CVSS 7.5) in Apache Apisix, published April 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 8.14%, the 94th percentile. Fixed in apisix 2.13.1.

References

MoveEnter Open