Every CVE Search/ Get API key

CVE-2022-2963

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug...

7.5 HighFix available

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

1.72%Up 0.8 points since Oct 15, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
CVE-2022-2963
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
CVE List 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
CVE-2022-2963
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
EUVDEUVD-2022-35184 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
EUVD-2022-35184
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-g89h-fpvv-hmhh 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug...

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
GHSA-g89h-fpvv-hmhh
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-401
Updated
2026-11-02
OSV 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
CVE-2022-2963
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSVUBUNTU-CVE-2022-2963 7.5

A vulnerability found in jasper. This security vulnerability happens because of a memory leak bug in function cmdopts_parse that can cause a crash or segmentation fault.

Record
UBUNTU-CVE-2022-2963
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
Show 5 moreShow less
OSVCLSA-2026-1792566014 No score

jasper: Fix of CVE-2022-2963

  • CVE-2022-2963: fix memory leak in cmdopts_parse() — add cmdopts_destroy() before badusage() in the default case and the missing-output-format check
Record
CLSA-2026-1792566014
Updated
2026-11-02
OSVMGASA-2023-0091 No score

Updated jasper packages fix security vulnerability

Memory leak in function cmdopts_parse that can cause a crash or segmentation fault. (CVE-2022-2963)

Record
MGASA-2023-0091
Updated
2026-11-02
OSVopenSUSE-SU-2024:12338-1 No score

jasper-3.0.6-2.1 on GA media

These are all security issues fixed in the jasper-3.0.6-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12338-1
Updated
2026-11-02
OSVSUSE-SU-2022:3672-1 No score

Security update for jasper

This update for jasper fixes the following issues:

  • CVE-2022-2963: Fixed memory leaks in function cmdopts_parse (bsc#1202642).
Record
SUSE-SU-2022:3672-1
Updated
2026-11-02
OSVSUSE-SU-2022:3673-1 No score

Security update for jasper

This update for jasper fixes the following issues:

  • CVE-2022-2963: Fixed memory leaks in function cmdopts_parse (bsc#1202642).
Record
SUSE-SU-2022:3673-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
jasper
TuxCare:AlmaLinux:9.2
before 2.0.28-3.el9.tuxcare.els5
2.0.28-3.el9.tuxcare.els5
jasper-devel
TuxCare:AlmaLinux:9.2
before 2.0.28-3.el9.tuxcare.els5
2.0.28-3.el9.tuxcare.els5
jasper-libs
TuxCare:AlmaLinux:9.2
before 2.0.28-3.el9.tuxcare.els5
2.0.28-3.el9.tuxcare.els5
jasper-utils
TuxCare:AlmaLinux:9.2
before 2.0.28-3.el9.tuxcare.els5
2.0.28-3.el9.tuxcare.els5
jasper
Mageia:8
before 2.0.27-1.1.mga8
2.0.27-1.1.mga8
jasper
SUSE:Linux Enterprise Software Development Kit 12 SP5
before 1.900.14-195.34.1
1.900.14-195.34.1
jasper
SUSE:Linux Enterprise Server 12 SP5
before 1.900.14-195.34.1
1.900.14-195.34.1
jasper
SUSE:Linux Enterprise Server for SAP Applications 12 SP5
before 1.900.14-195.34.1
1.900.14-195.34.1
jasper
SUSE:Linux Enterprise Module for Basesystem 15 SP3
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
jasper
SUSE:Linux Enterprise Module for Basesystem 15 SP4
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
Show 6 moreShow less
Affected packages
PackageAffectedFixed
jasper
SUSE:Linux Enterprise Module for Desktop Applications 15 SP3
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
jasper
SUSE:Linux Enterprise Module for Desktop Applications 15 SP4
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
jasper
openSUSE:Leap 15.3
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
jasper
openSUSE:Leap 15.4
before 2.0.14-150000.3.28.1
2.0.14-150000.3.28.1
jasper
Ubuntu:16.04:LTS
All versions, plus listed versions
1.900.1-debian1-2.41.900.1-debian1-2.4ubuntu11.900.1-debian1-2.4ubuntu1.11.900.1-debian1-2.4ubuntu1.21.900.1-debian1-2.4ubuntu1.3
None known
jasper
openSUSE:Tumbleweed
before 3.0.6-2.1
3.0.6-2.1

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-2963 is a high vulnerability (CVSS 7.5) in Jasper Project Jasper, published October 14, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.72%, the 77th percentile. Fixed in jasper 2.0.28-3.el9.tuxcare.els5.

References

Show 13 moreShow less
MoveEnter Open