Every CVE Search/ Get API key

CVE-2022-29806

ZoneMinder before 1.36.13 allows remote code execution via an invalid language.

9.8 CriticalPublic exploitFix available

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

67.1%Up 62.7 points since Apr 26, 2022
90%50%10%1%

What each source reports

NVD Score used 9.8

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
CVE-2022-29806
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
CVSS 2.0
7.5 HighAV:N/AC:L/Au:N/C:P/I:P/A:P
Weakness
CWE-22
Updated
2026-11-02
CVE List No score

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
CVE-2022-29806
Updated
2026-11-02
EUVDEUVD-2022-34127 No score

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
EUVD-2022-34127
Updated
2026-11-03
GitHub AdvisoriesGHSA-xr7v-8xc4-62vc 9.8

ZoneMinder before 1.36.13 allows remote code execution via an invalid language.

ZoneMinder before 1.36.13 allows remote code execution via an invalid language.

Record
GHSA-xr7v-8xc4-62vc
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-22
Updated
2026-11-02
OSVUBUNTU-CVE-2022-29806 9.8

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
UBUNTU-CVE-2022-29806
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Updated
2026-11-02
OSV No score

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
CVE-2022-29806
Updated
2026-11-02
OSVDEBIAN-CVE-2022-29806 No score

ZoneMinder before 1.36.13 allows remote code execution via an invalid language. Ability to create a debug log file at an arbitrary pathname contributes to exploitability.

Record
DEBIAN-CVE-2022-29806
Updated
2026-11-03
OSVUSN-5889-1 No score

zoneminder vulnerabilities

It was discovered that ZoneMinder was not properly sanitizing URL parameters for certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6777)

It was discovered that ZoneMinder was not properly sanitizing stored user input later printed to the user in certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6990, CVE-2019-6992)

It was discovered that ZoneMinder was not properly limiting data size and not properly performing bound checks when processing username and password data, which could lead to a stack buffer overflow. An attacker could possibly use this issue to bypass authentication, cause a denial of service or execute arbitrary code. This issue was only fixed in Ubuntu 16.04 ESM. (CVE-2019-6991)

It was discovered that ZoneMinder was not properly defining and filtering data that was appended to the webroot URL of a view. An attacker could possibly use this issue to perform cross-site scripting (XSS) attacks. This issue was only fixed in Ubuntu 16.04 ESM and Ubuntu 20.04 ESM. (CVE-2019-7325, CVE-2019-7329)

It was discovered that ZoneMinder was not properly sanitizing stored user input later printed to the user in certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 20.04 ESM. (CVE-2019-7326)

It was discovered that ZoneMinder was not properly sanitizing URL parameters for certain views. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 20.04 ESM. (CVE-2019-7327, CVE-2019-7328, CVE-2019-7330, CVE-2019-7332)

It was discovered that ZoneMinder was not properly sanitizing user input in the monitor editing view. An attacker could possibly use this issue to perform a cross-site scripting (XSS) attack. This issue was only fixed in Ubuntu 16.04 ESM and Ubuntu 20.04 ESM. (CVE-2019-7331)

It was discovered that ZoneMinder was not properly sanitizing data related to file paths in a system. An attacker could possibly use this issue to execute arbitrary code. (CVE-2022-29806)

Record
USN-5889-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
zoneminder
Debian:12
before 1.36.13+dfsg1-1
1.36.13+dfsg1-1
zoneminder
Debian:13
before 1.36.13+dfsg1-1
1.36.13+dfsg1-1
zoneminder
Debian:14
before 1.36.13+dfsg1-1
1.36.13+dfsg1-1
zoneminder
Ubuntu:Pro:16.04:LTS
before 1.29.0+dfsg-1ubuntu2+esm1, plus listed versions
1.28.1-81.29.0+dfsg-11.29.0+dfsg-1ubuntu11.29.0+dfsg-1ubuntu2
1.29.0+dfsg-1ubuntu2+esm1
zoneminder
Ubuntu:Pro:20.04:LTS
before 1.32.3-2ubuntu2+esm1, plus listed versions
1.32.3-2build11.32.3-2ubuntu11.32.3-2ubuntu2
1.32.3-2ubuntu2+esm1
zoneminder
Ubuntu:Pro:22.04:LTS
before 1.36.12+dfsg1-1ubuntu0.1~esm1, plus listed versions
1.36.7+dfsg1-11.36.10+dfsg1-11.36.11+dfsg1-11.36.12+dfsg1-1
1.36.12+dfsg1-1ubuntu0.1~esm1
zoneminder
Ubuntu:Pro:16.04:LTS
From an advisory covering 13 CVEs
before 1.29.0+dfsg-1ubuntu2+esm1, plus listed versions
1.28.1-81.29.0+dfsg-11.29.0+dfsg-1ubuntu11.29.0+dfsg-1ubuntu2
1.29.0+dfsg-1ubuntu2+esm1
zoneminder
Ubuntu:Pro:20.04:LTS
From an advisory covering 13 CVEs
before 1.32.3-2ubuntu2+esm1, plus listed versions
1.32.3-2build11.32.3-2ubuntu11.32.3-2ubuntu2
1.32.3-2ubuntu2+esm1
zoneminder
Ubuntu:Pro:22.04:LTS
From an advisory covering 13 CVEs
before 1.36.12+dfsg1-1ubuntu0.1~esm1, plus listed versions
1.36.7+dfsg1-11.36.10+dfsg1-11.36.11+dfsg1-11.36.12+dfsg1-1
1.36.12+dfsg1-1ubuntu0.1~esm1

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
MetasploitZoneMinder Language Settings Remote Code Execution2022-04-27
PoC in GitHubSigm0n/CVE-2022-298062025-04-28

History

History
RecordedChangedSources
affected, factsOSV
aliasesEUVD
first indexedCVE List, GitHub Advisories, Metasploit, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-29806 is a critical vulnerability (CVSS 9.8) in Zoneminder, published April 26, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 67.1%, the 99th percentile. Fixed in zoneminder 1.36.13+dfsg1-1.

References

Show 18 moreShow less
MoveEnter Open