Every CVE Search/ Get API key

CVE-2022-29822

Feathers - Improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

10.0 CriticalFix available

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
High

Exploit likelihood

0.93%Unchanged since Oct 27, 2022
90%50%10%1%

What each source reports

CVE List Score used 10.0

Feathers - Improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Record
CVE-2022-29822
CVSS 3.1
10.0 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
EUVDEUVD-2022-7026 10.0

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Record
EUVD-2022-7026
CVSS 3.1
10.0 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Updated
2026-11-02
GitHub AdvisoriesGHSA-5hq7-j5wq-p227 9.8

feathers-sequelize vulnerable to SQL injection due to improper parameter filtering

feathers-sequelize is vulnerable to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection.

Record
GHSA-5hq7-j5wq-p227
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
NVD 10.0

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Record
CVE-2022-29822
CVSS 3.1
10.0 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSV 10.0

Feathers - Improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Due to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection

Record
CVE-2022-29822
CVSS 3.1
10.0 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02
OSVGHSA-5hq7-j5wq-p227 9.8

feathers-sequelize vulnerable to SQL injection due to improper parameter filtering

feathers-sequelize is vulnerable to improper parameter filtering in the Feathers js library, which may ultimately lead to SQL injection.

Record
GHSA-5hq7-j5wq-p227
CVSS 3.1
9.8 CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-89
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
feathers-sequelize
npm
6.0.0 up to 6.3.4
6.3.4

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-29822 is a critical vulnerability (CVSS 10.0) in Feather Js Feathers-sequalize, published October 25, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.93%, the 60th percentile. Fixed in feathers-sequelize 6.3.4.

References

MoveEnter Open