CVE-2022-30241
Cross-site Scripting in jquery.json-viewer
The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
CVE-2022-30241- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
CVE-2022-30241- Updated
- 2026-11-02
EUVDEUVD-2022-5005 No score
The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
EUVD-2022-5005- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-qp2q-6h9j-jg2r
6.1
Cross-site Scripting in jquery.json-viewer
The jquery.json-viewer library before version 1.5.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
GHSA-qp2q-6h9j-jg2r- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-qp2q-6h9j-jg2r
6.1
Cross-site Scripting in jquery.json-viewer
The jquery.json-viewer library before version 1.5.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
GHSA-qp2q-6h9j-jg2r- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV No score
The jquery.json-viewer library through 1.4.0 for Node.js does not properly escape characters such as < in a JSON object, as demonstrated by a SCRIPT element.
- Record
CVE-2022-30241- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
jquery.json-viewernpm |
before 1.5.0 | 1.5.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-30241 is a medium vulnerability (CVSS 6.1) in Jquery Json-viewer Project Json-viewer, published May 4, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.71%, the 53rd percentile. Fixed in jquery.json-viewer 1.5.0.
References
github.com/abodelot/jquery.json-viewer/pull/26
npmjs.com/package/jquery.json-viewer
nvd.nist.gov/vuln/detail/CVE-2022-30241
github.com/abodelot/jquery.json-viewer/releases/tag/v1.5.0
github.com/advisories/GHSA-qp2q-6h9j-jg2r
github.com/CVEProject/cvelistV5/tree/main/cves/2022/30xxx/CVE-2022-30241.json
github.com/abodelot/jquery.json-viewer