CVE-2022-30688
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect...
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
7.8
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
CVE-2022-30688- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - CVSS 2.0
- 4.6 Medium
AV:L/AC:L/Au:N/C:P/I:P/A:P - Updated
- 2026-11-02
CVE List No score
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
CVE-2022-30688- Updated
- 2026-11-02
EUVDEUVD-2022-52519 No score
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
EUVD-2022-52519- Updated
- 2026-11-02
GitHub AdvisoriesGHSA-6qgc-vw4g-mxw4
7.8
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect...
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
GHSA-6qgc-vw4g-mxw4- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-269
- Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-30688
7.8
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
DEBIAN-CVE-2022-30688- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-30688
7.8
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
UBUNTU-CVE-2022-30688- CVSS 3.1
- 7.8 High
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVCLSA-2025-1764324770 No score
Fix CVE(s): CVE-2022-30688
- SECURITY UPDATE: insecure regex patterns for interpreter detection
- debian/patches/CVE-2022-30688.patch: prevent local privilege escalation by anchoring interpreter regex patterns
- CVE-2022-30688
- Record
CLSA-2025-1764324770- Updated
- 2026-11-02
OSV No score
needrestart 0.8 through 3.5 before 3.6 is prone to local privilege escalation. Regexes to detect the Perl, Python, and Ruby interpreters are not anchored, allowing a local user to escalate privileges when needrestart tries to detect if interpreters are using old source files.
- Record
CVE-2022-30688- Updated
- 2026-11-02
OSVUSN-5426-1 No score
needrestart vulnerability
Jakub Wilk discovered that needrestart incorrectly used some regular expressions. A local attacker could possibly use this issue to execute arbitrary code.
- Record
USN-5426-1- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
needrestartTuxCare:Ubuntu:16.04 |
before 2.6-1+tuxcare.els2 | 2.6-1+tuxcare.els2 |
needrestartDebian:12 |
before 3.6-1 | 3.6-1 |
needrestartDebian:13 |
before 3.6-1 | 3.6-1 |
needrestartDebian:14 |
before 3.6-1 | 3.6-1 |
needrestartDebian:9 |
before 2.11-3+deb9u2, plus listed versions 2.11-32.11-3+deb9u1 |
2.11-3+deb9u2 |
needrestartDebian:10 |
before 3.4-5+deb10u1, plus listed versions 3.4-5 |
3.4-5+deb10u1 |
needrestartDebian:11 |
before 3.5-4+deb11u1, plus listed versions 3.5-4 |
3.5-4+deb11u1 |
needrestartUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.1-12.3-22.4-12.5-12.6-12.6-1ubuntu0.1~esm12.6-1ubuntu0.1~esm22.6-1ubuntu0.1~esm3 |
None known |
needrestartUbuntu:18.04:LTS |
before 3.1-1ubuntu0.1, plus listed versions 2.11-43.0-13.1-1 |
3.1-1ubuntu0.1 |
needrestartUbuntu:20.04:LTS |
before 3.4-6ubuntu0.1, plus listed versions 3.4-53.4-6 |
3.4-6ubuntu0.1 |
needrestartUbuntu:22.04:LTS |
before 3.5-5ubuntu2.1, plus listed versions 3.5-4ubuntu23.5-5ubuntu13.5-5ubuntu2 |
3.5-5ubuntu2.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-30688 is a high vulnerability (CVSS 7.8) in Needrestart Project Needrestart, published May 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.40%, the 34th percentile. Fixed in needrestart 2.6-1+tuxcare.els2.
References
github.com/liske/needrestart/releases/tag/v3.6
github.com/liske/needrestart/commit/e6e58136e1e3c92296e2e810cb8372a5fe0dbd30
lists.debian.org/debian-security-announce/2022/msg00105.html
openwall.com/lists/oss-security/2022/05/17/9
debian.org/security/2022/dsa-5137
lists.debian.org/debian-lts-announce/2022/05/msg00024.html
Show 10 moreShow less
seclists.org/fulldisclosure/2024/Nov/17
seclists.org/fulldisclosure/2024/Nov/15
nvd.nist.gov/vuln/detail/CVE-2022-30688
github.com/advisories/GHSA-6qgc-vw4g-mxw4
errata.tuxcare.com/els_os/ubuntu16.04els/CLSA-2025-1764324770.html
github.com/CVEProject/cvelistV5/tree/main/cves/2022/30xxx/CVE-2022-30688.json
security-tracker.debian.org/tracker/CVE-2022-30688
ubuntu.com/security/CVE-2022-30688
ubuntu.com/security/notices/USN-5426-1
cve.org/CVERecord?id=CVE-2022-30688