Every CVE Search/ Get API key

CVE-2022-30780

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU...

7.5 HighPublic exploitFix available

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
None
Availability
High

Exploit likelihood

57.2%Up 55.5 points since Jun 12, 2022
90%50%10%1%

What each source reports

NVD Score used 7.5

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
CVE-2022-30780
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 2.0
5.0 MediumAV:N/AC:L/Au:N/C:N/I:N/A:P
Weakness
CWE-682
Updated
2026-11-02
CVE List No score

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
CVE-2022-30780
Updated
2026-11-02
EUVDEUVD-2022-52604 No score

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
EUVD-2022-52604
Updated
2026-11-03
GitHub AdvisoriesGHSA-43hv-3rv7-ch5p 7.5

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU...

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
GHSA-43hv-3rv7-ch5p
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weakness
CWE-400
Updated
2026-11-02
OSVDEBIAN-CVE-2022-30780 7.5

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
DEBIAN-CVE-2022-30780
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-03
OSVUBUNTU-CVE-2022-30780 7.5

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
UBUNTU-CVE-2022-30780
CVSS 3.1
7.5 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Updated
2026-11-02
OSV No score

Lighttpd 1.4.56 through 1.4.58 allows a remote attacker to cause a denial of service (CPU consumption from stuck connections) because connection_read_header_more in connections.c has a typo that disrupts use of multiple read operations on large headers.

Record
CVE-2022-30780
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
lighttpd
Debian:12
before 1.4.59-1
1.4.59-1
lighttpd
Debian:13
before 1.4.59-1
1.4.59-1
lighttpd
Debian:14
before 1.4.59-1
1.4.59-1
lighttpd
Ubuntu:Pro:16.04:LTS
All versions, plus listed versions
1.4.35-4ubuntu11.4.35-4ubuntu21.4.35-4ubuntu2.11.4.35-4ubuntu2.1+esm1
None known

Public exploits

Links only. Every CVE stores no exploit code.

Public exploits
SourceLinkDate
PoC in GitHubp0dalirius/CVE-2022-30780-lighttpd-denial-of-service2022-05-18
PoC in GitHubxiw1ll/CVE-2022-30780_Checker2024-07-18

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV, PoC in GitHub

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-30780 is a high vulnerability (CVSS 7.5) in Lighttpd, published June 11, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 57.2%, the 99th percentile. Fixed in lighttpd 1.4.59-1.

References

Show 4 moreShow less
MoveEnter Open