Every CVE Search/ Get API key

CVE-2022-31048

Cross-Site Scripting in Form Framework

5.4 MediumFix available

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
Required

What an attacker can affect

Confidentiality
Low
Integrity
Low
Availability
None

Exploit likelihood

0.78%Down 0.1 points since Jun 15, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.4

Cross-Site Scripting in Form Framework

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Record
CVE-2022-31048
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-5911 5.4

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Record
EUVD-2022-5911
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-3r95-23jp-mhvg 5.4

Cross-Site Scripting in TYPO3's Form Framework

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.9)

Problem

It has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 8.7.47 ELTS, 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above.

Credits

Thanks to Gabe Troyan who reported and fixed the issue.

References

Record
GHSA-3r95-23jp-mhvg
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Record
CVE-2022-31048
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 2.0
3.5 LowAV:N/AC:M/Au:S/C:N/I:P/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.4

Cross-Site Scripting in Form Framework

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Record
CVE-2022-31048
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-3r95-23jp-mhvg 5.4

Cross-Site Scripting in TYPO3's Form Framework

Meta

  • CVSS: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC:C (4.9)

Problem

It has been discovered that the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability.

Solution

Update to TYPO3 versions 8.7.47 ELTS, 9.5.35 ELTS, 10.4.29, 11.5.11 that fix the problem described above.

Credits

Thanks to Gabe Troyan who reported and fixed the issue.

References

Record
GHSA-3r95-23jp-mhvg
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVBIT-typo3-2022-31048 No score

TYPO3 is an open source web content management system. Prior to versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11, the Form Designer backend module of the Form Framework is vulnerable to cross-site scripting. A valid backend user account with access to the form module is needed to exploit this vulnerability. TYPO3 versions 8.7.47 ELTS, 9.5.34 ELTS, 10.4.29, and 11.5.11 contain a fix for the problem.

Record
BIT-typo3-2022-31048
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
typo3/cms-core
Packagist
8.0.0 up to 8.7.47
8.7.47
typo3/cms-core
Packagist
9.0.0 up to 9.5.35
9.5.35
typo3/cms-core
Packagist
10.0.0 up to 10.4.29
10.4.29
typo3/cms-core
Packagist
11.0.0 up to 11.5.11
11.5.11
typo3/cms
Packagist
10.0.0 up to 10.4.29
10.4.29
typo3/cms
Packagist
11.0.0 up to 11.5.11
11.5.11
typo3
Bitnami
8.0.0 up to 8.7.47, 9.0.0 up to 9.5.35, 10.0.0 up to 10.4.29, 11.0.0 up to 11.5.11
8.7.479.5.3510.4.2911.5.11
typo3/cms-core
Packagist
8.0.0 up to 8.7.47, plus listed versions
v8.7.10v8.7.11v8.7.12v8.7.13v8.7.14
Show 21 moreShow less
v8.7.15v8.7.16v8.7.17v8.7.18v8.7.19v8.7.20v8.7.21v8.7.22v8.7.23v8.7.24v8.7.25v8.7.26v8.7.27v8.7.28v8.7.29v8.7.30v8.7.31v8.7.32v8.7.7v8.7.8v8.7.9
8.7.47
typo3/cms-core
Packagist
9.0.0 up to 9.5.35, plus listed versions
v9.0.0v9.1.0v9.2.0v9.2.1v9.3.0
Show 36 moreShow less
v9.3.1v9.3.2v9.3.3v9.4.0v9.5.0v9.5.1v9.5.10v9.5.11v9.5.12v9.5.13v9.5.14v9.5.15v9.5.16v9.5.17v9.5.18v9.5.19v9.5.2v9.5.20v9.5.21v9.5.22v9.5.23v9.5.24v9.5.25v9.5.26v9.5.27v9.5.28v9.5.29v9.5.3v9.5.30v9.5.31v9.5.4v9.5.5v9.5.6v9.5.7v9.5.8v9.5.9
9.5.35
typo3/cms-core
Packagist
10.0.0 up to 10.4.29, plus listed versions
v10.0.0v10.1.0v10.2.0v10.2.1v10.2.2
Show 30 moreShow less
v10.3.0v10.4.0v10.4.1v10.4.10v10.4.11v10.4.12v10.4.13v10.4.14v10.4.15v10.4.16v10.4.17v10.4.18v10.4.19v10.4.2v10.4.20v10.4.21v10.4.22v10.4.23v10.4.24v10.4.25v10.4.26v10.4.27v10.4.28v10.4.3v10.4.4v10.4.5v10.4.6v10.4.7v10.4.8v10.4.9
10.4.29
typo3/cms-core
Packagist
11.0.0 up to 11.5.11, plus listed versions
v11.0.0v11.1.0v11.1.1v11.2.0v11.3.0
Show 15 moreShow less
v11.3.1v11.3.2v11.3.3v11.4.0v11.5.0v11.5.1v11.5.10v11.5.2v11.5.3v11.5.4v11.5.5v11.5.6v11.5.7v11.5.8v11.5.9
11.5.11
typo3/cms
Packagist
10.0.0 up to 10.4.29, plus listed versions
v10.0.0v10.1.0v10.2.0v10.2.1v10.2.2
Show 30 moreShow less
v10.3.0v10.4.0v10.4.1v10.4.10v10.4.11v10.4.12v10.4.13v10.4.14v10.4.15v10.4.16v10.4.17v10.4.18v10.4.19v10.4.2v10.4.20v10.4.21v10.4.22v10.4.23v10.4.24v10.4.25v10.4.26v10.4.27v10.4.28v10.4.3v10.4.4v10.4.5v10.4.6v10.4.7v10.4.8v10.4.9
10.4.29
typo3/cms
Packagist
11.0.0 up to 11.5.11, plus listed versions
v11.0.0v11.1.0v11.1.1v11.2.0v11.3.0
Show 15 moreShow less
v11.3.1v11.3.2v11.3.3v11.4.0v11.5.0v11.5.1v11.5.10v11.5.2v11.5.3v11.5.4v11.5.5v11.5.6v11.5.7v11.5.8v11.5.9
11.5.11

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-31048 is a medium vulnerability (CVSS 5.4) in Typo3, published June 14, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.78%, the 56th percentile. Fixed in typo3/cms-core 8.7.47.

References

MoveEnter Open