CVE-2022-31070
Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. This issue has been fixed in version 0.7.0 of @finastra/nestjs-proxy. Users of @ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use @finastra/nestjs-proxy instead.
Attack profile
How easy it is to exploit
- Attack vector
- Local
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
5.8
Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. This issue has been fixed in version 0.7.0 of @finastra/nestjs-proxy. Users of @ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use @finastra/nestjs-proxy instead.
- Record
CVE-2022-31070- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
EUVDEUVD-2022-5976
5.8
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. This issue has been fixed in version 0.7.0 of @finastra/nestjs-proxy. Users of @ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use @finastra/nestjs-proxy instead.
- Record
EUVD-2022-5976- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-77mv-4rg7-r8qv
5.8
Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
The nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them.
The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. Further details of this feature can be found in the library's README on Github or NPM.
Patches
- This issue has been fixed in version 0.7.0 of
@finastra/nestjs-proxy. - Users of
@ffdc/nestjs-proxyare advised that this package has been deprecated and is no longer being maintained or receiving updates. Please update your package.json file to use@finastra/nestjs-proxyinstead.
References
- Record
GHSA-77mv-4rg7-r8qv- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
NVD
5.8
NestJS Proxy is a NestJS module to decorate and proxy calls. Prior to version 0.7.0, the nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them. The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. This issue has been fixed in version 0.7.0 of @finastra/nestjs-proxy. Users of @ffdc/nestjs-proxy are advised that this package has been deprecated and is no longer being maintained or receiving updates. Such users should update their package.json file to use @finastra/nestjs-proxy instead.
- Record
CVE-2022-31070- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N - CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 2.0
- 5.0 Medium
AV:N/AC:L/Au:N/C:P/I:N/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
OSVGHSA-77mv-4rg7-r8qv
5.8
Potential Sensitive Cookie Exposure in NPM Packages @finastra/nestjs-proxy, @ffdc/nestjs-proxy
The nestjs-proxy library did not have a way to block sensitive cookies (e.g. session cookies) from being forwarded to backend services configured by the application developer. This could have led to sensitive cookies being inadvertently exposed to such services that should not see them.
The patched version now blocks cookies from being forwarded by default. However developers can configure an allow-list of cookie names by using the allowedCookies config setting. Further details of this feature can be found in the library's README on Github or NPM.
Patches
- This issue has been fixed in version 0.7.0 of
@finastra/nestjs-proxy. - Users of
@ffdc/nestjs-proxyare advised that this package has been deprecated and is no longer being maintained or receiving updates. Please update your package.json file to use@finastra/nestjs-proxyinstead.
References
- Record
GHSA-77mv-4rg7-r8qv- CVSS 3.1
- 5.8 Medium
CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N - Weakness
- CWE-200
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
@finastra/nestjs-proxynpm |
before 0.7.0 | 0.7.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-31070 is a medium vulnerability (CVSS 5.8) in Finastra Nestjs-proxy, published June 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.66%, the 51st percentile. Fixed in @finastra/nestjs-proxy 0.7.0.