Every CVE Search/ Get API key

CVE-2022-31250

keylime %post scriplet allows for privilege escalation from keylime user to root

7.1 High

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.32%Down 0.6 points since Jul 20, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.1

keylime %post scriplet allows for privilege escalation from keylime user to root

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.

Record
CVE-2022-31250
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weakness
CWE-59
Updated
2026-11-02
EUVDEUVD-2022-52827 7.1

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.

Record
EUVD-2022-52827
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-frfj-3v3x-pvwx 7.8

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows...

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.

Record
GHSA-frfj-3v3x-pvwx
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-59
Updated
2026-11-02
NVD 7.1

A UNIX Symbolic Link (Symlink) Following vulnerability in keylime of openSUSE Tumbleweed allows local attackers to escalate from the keylime user to root. This issue affects: openSUSE Tumbleweed keylime versions prior to 6.4.2-1.1.

Record
CVE-2022-31250
CVSS 3.1
7.1 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1
7.8 HighCVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-59
Updated
2026-11-02
OSVopenSUSE-SU-2024:12153-1 No score

keylime-agent-6.4.1-2.1 on GA media

These are all security issues fixed in the keylime-agent-6.4.1-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12153-1
Updated
2026-11-02
OSVSUSE-SU-2022:2658-1 No score

Security update for keylime

This update for keylime fixes the following issues:

Update to version 6.3.2, including fixes for:

  • CVE-2022-1053: Fixed Tenant and Verifier might not use the same registrar data (bsc#1199253).
  • CVE-2022-31250: Fixed %post scriplet allows for privilege escalation from keylime user to root (bsc#1200885).
Record
SUSE-SU-2022:2658-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
keylime
SUSE:Linux Enterprise Module for Basesystem 15 SP4
From an advisory covering 2 CVEs
before 6.3.2-150400.4.11.1
6.3.2-150400.4.11.1
keylime
openSUSE:Leap 15.4
From an advisory covering 2 CVEs
before 6.3.2-150400.4.11.1
6.3.2-150400.4.11.1

History

History
RecordedChangedSources
affected, facts
aliases, publishedEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-31250 is a high vulnerability (CVSS 7.1) in Opensuse Tumbleweed, published July 20, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.32%, the 25th percentile. No source names a fixed version.

References

Show 4 moreShow less
MoveEnter Open