CVE-2022-3167
Improper Restriction of Rendered UI Layers or Frames in ikus060/rdiffweb
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
10.0
Improper Restriction of Rendered UI Layers or Frames in ikus060/rdiffweb
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
- Record
CVE-2022-3167- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-1021
- Updated
- 2026-11-02
EUVDEUVD-2022-0228
10.0
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
- Record
EUVD-2022-0228- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
GitHub AdvisoriesGHSA-m379-x4xc-38x9
9.3
rdiffweb vulnerable to Improper Restriction of Rendered UI Layers or Frames
rdiffweb prior to 2.4.1 is vulnerable to Improper Restriction of Rendered UI Layers or Frames. This allows attackers to perform clickjacking attacks that can trick victims into performing actions such as entering passwords, liking or deleting posts, and/or initiating an account deletion. This issue has been patched in version 2.4.1.
- Record
GHSA-m379-x4xc-38x9- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-1021
- Updated
- 2026-11-02
NVD
8.8
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
- Record
CVE-2022-3167- CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-1021
- Updated
- 2026-11-02
OSV
10.0
Improper Restriction of Rendered UI Layers or Frames in ikus060/rdiffweb
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
- Record
CVE-2022-3167- CVSS 3.0
- 10.0 Critical
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-1021
- Updated
- 2026-11-02
OSVGHSA-m379-x4xc-38x9
9.3
rdiffweb vulnerable to Improper Restriction of Rendered UI Layers or Frames
rdiffweb prior to 2.4.1 is vulnerable to Improper Restriction of Rendered UI Layers or Frames. This allows attackers to perform clickjacking attacks that can trick victims into performing actions such as entering passwords, liking or deleting posts, and/or initiating an account deletion. This issue has been patched in version 2.4.1.
- Record
GHSA-m379-x4xc-38x9- CVSS 4.0
- 9.3 Critical
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N - CVSS 3.1
- 8.8 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-1021
- Updated
- 2026-11-02
OSVPYSEC-2022-268 No score
Improper Restriction of Rendered UI Layers or Frames in GitHub repository ikus060/rdiffweb prior to 2.4.1.
- Record
PYSEC-2022-268- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
rdiffwebPyPI |
before 2.4.1 | 2.4.1 |
rdiffwebPyPI |
before 2.4.1, plus listed versions 0.10.00.10.20.10.30.10.40.10.5 Show 45 moreShow less0.10.60.10.70.10.80.10.90.9.2.dev10.9.30.9.40.9.51.0.01.0.0a11.0.0a21.0.0a31.0.0a41.0.11.0.21.0.31.1.01.2.01.2.11.2.21.3.01.3.11.3.1b11.3.1b21.3.21.4.01.4.0b11.4.0b21.4.0b31.4.0b41.4.0b51.4.1b11.4.1b21.4.1b31.5.01.5.1b11.5.1b21.6.0b12.0.1b22.0.1b32.0.22.0.3a12.0.3a22.0.3a32.0.3a4 |
2.4.1 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-3167 is a critical vulnerability (CVSS 10.0) in Ikus-soft Rdiffweb, published September 8, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.19%, the 68th percentile. Fixed in rdiffweb 2.4.1.
References
huntr.dev/bounties/e5c2625b-34cc-4805-8223-80f2689e4e5c
github.com/ikus060/rdiffweb/commit/7294bb7466532762c93d711211e5958940c1b428
nvd.nist.gov/vuln/detail/CVE-2022-3167
github.com/pypa/advisory-database/tree/main/vulns/rdiffweb/PYSEC-2022-268.yaml
github.com/advisories/GHSA-m379-x4xc-38x9
github.com/CVEProject/cvelistV5/tree/main/cves/2022/3xxx/CVE-2022-3167.json
github.com/ikus060/rdiffweb
Left out here: 24 versions. The JSON record has them.