Every CVE Search/ Get API key

CVE-2022-3179

Weak Password Requirements in ikus060/rdiffweb

7.1 HighFix available

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

1.00%Up 0.1 points since Sep 14, 2022
90%50%10%1%

What each source reports

CVE List Score used 7.1

Weak Password Requirements in ikus060/rdiffweb

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Record
CVE-2022-3179
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-521
Updated
2026-11-02
EUVDEUVD-2022-0230 7.1

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Record
EUVD-2022-0230
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-mp5p-g2jv-r8qw 8.7

rdiffweb contains Weak Password Requirements

rdiffweb version 2.4.1 has no password policy or password checking, which could make users vulnerable to brute force password guessing attacks. Version 2.4.2 enforces minimum and maximum password lengths.

Record
GHSA-mp5p-g2jv-r8qw
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-521
Updated
2026-11-02
NVD 8.8

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Record
CVE-2022-3179
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-521
Updated
2026-11-02
OSV 7.1

Weak Password Requirements in ikus060/rdiffweb

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Record
CVE-2022-3179
CVSS 3.0
7.1 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-521
Updated
2026-11-02
OSVGHSA-mp5p-g2jv-r8qw 8.7

rdiffweb contains Weak Password Requirements

rdiffweb version 2.4.1 has no password policy or password checking, which could make users vulnerable to brute force password guessing attacks. Version 2.4.2 enforces minimum and maximum password lengths.

Record
GHSA-mp5p-g2jv-r8qw
CVSS 4.0
8.7 HighCVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weakness
CWE-521
Updated
2026-11-02
OSVPYSEC-2022-272 No score

Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2.

Record
PYSEC-2022-272
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
rdiffweb
PyPI
2.4.1 to 2.4.1
2.4.2
rdiffweb
PyPI
2.4.1 up to 2.4.2
2.4.2
rdiffweb
PyPI
before 2.4.2, plus listed versions
0.10.00.10.20.10.30.10.40.10.5
Show 45 moreShow less
0.10.60.10.70.10.80.10.90.9.2.dev10.9.30.9.40.9.51.0.01.0.0a11.0.0a21.0.0a31.0.0a41.0.11.0.21.0.31.1.01.2.01.2.11.2.21.3.01.3.11.3.1b11.3.1b21.3.21.4.01.4.0b11.4.0b21.4.0b31.4.0b41.4.0b51.4.1b11.4.1b21.4.1b31.5.01.5.1b11.5.1b21.6.0b12.0.1b22.0.1b32.0.22.0.3a12.0.3a22.0.3a32.0.3a4
2.4.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-3179 is a high vulnerability (CVSS 7.1) in Ikus-soft Rdiffweb, published September 13, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.00%, the 63rd percentile. Fixed in rdiffweb 2.4.2.

References

This page doesn't list everything

Left out here: 25 versions. The JSON record has them.

MoveEnter Open