Every CVE Search/ Get API key

CVE-2022-3211

Cross-site Scripting (XSS) - Stored in pimcore/pimcore

5.8 MediumFix available

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.6.

Attack profile

How easy it is to exploit

Attack vector
Local
Complexity
Low
Privileges needed
High
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
High
Availability
None

Exploit likelihood

0.54%Down 0.3 points since Sep 16, 2022
90%50%10%1%

What each source reports

CVE List Score used 5.8

Cross-site Scripting (XSS) - Stored in pimcore/pimcore

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.6.

Record
CVE-2022-3211
CVSS 3.0
5.8 MediumCVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-6686 5.8

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.6.

Record
EUVD-2022-6686
CVSS 3.0
5.8 MediumCVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
Updated
2026-11-03
GitHub AdvisoriesGHSA-4849-x3jx-45qr 5.4

Pimcore vulnerable to stored stored Cross-site Scripting via`properties` when creating new users

Pimcore prior to 10.5.6 is vulnerable to stored cross-site scripting. This occurs when an attacker injects a payload when adding properties for a new user.

Record
GHSA-4849-x3jx-45qr
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.6.

Record
CVE-2022-3211
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
5.8 MediumCVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 5.8

Cross-site Scripting (XSS) - Stored in pimcore/pimcore

Cross-site Scripting (XSS) - Stored in GitHub repository pimcore/pimcore prior to 10.5.6.

Record
CVE-2022-3211
CVSS 3.0
5.8 MediumCVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-4849-x3jx-45qr 5.4

Pimcore vulnerable to stored stored Cross-site Scripting via`properties` when creating new users

Pimcore prior to 10.5.6 is vulnerable to stored cross-site scripting. This occurs when an attacker injects a payload when adding properties for a new user.

Record
GHSA-4849-x3jx-45qr
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
pimcore/pimcore
Packagist
before 10.5.6
10.5.6
pimcore/pimcore
Packagist
before 10.5.6, plus listed versions
10.0.82.2.02.2.12.2.22.3.0
Show 45 moreShow less
3.0.03.0.13.0.23.0.33.0.43.0.53.0.63.1.03.1.14.0.04.0.14.1.04.1.14.1.24.1.34.2.04.3.04.3.14.4.04.4.14.4.24.4.34.5.04.6.04.6.14.6.24.6.34.6.44.6.5v10.0.0v10.0.0-BETA1v10.0.0-BETA2v10.0.0-BETA3v10.0.0-BETA4v10.0.1v10.0.2v10.0.3v10.0.4v10.0.5v10.0.6v10.0.7v10.0.9v10.1.0v10.1.1v10.1.2
10.5.6

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-3211 is a medium vulnerability (CVSS 5.8) in Pimcore, published September 15, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.54%, the 45th percentile. Fixed in pimcore/pimcore 10.5.6.

References

This page doesn't list everything

Left out here: 146 versions. The JSON record has them.

MoveEnter Open