CVE-2022-32174
Gogs - XSS
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
NVD Score used
9.0
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
CVE-2022-32174- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List
9.0
Gogs - XSS
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
CVE-2022-32174- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-7125
9.0
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
EUVD-2022-7125- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-mcjj-2fvq-mc3r
9.0
Gogs vulnerable to Cross-site Scripting
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
GHSA-mcjj-2fvq-mc3r- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVALPINE-CVE-2022-32174
9.0
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
ALPINE-CVE-2022-32174- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
OSV
9.0
Gogs - XSS
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
CVE-2022-32174- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-mcjj-2fvq-mc3r
9.0
Gogs vulnerable to Cross-site Scripting
In Gogs, versions v0.6.5 through v0.12.10 are vulnerable to Stored Cross-Site Scripting (XSS) that leads to an account takeover.
- Record
GHSA-mcjj-2fvq-mc3r- CVSS 3.1
- 9.0 Critical
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGO-2022-1060 No score
Gogs vulnerable to Cross-site Scripting in gogs.io/gogs
Gogs vulnerable to Cross-site Scripting in gogs.io/gogs
- Record
GO-2022-1060- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
gogs.io/gogsGo |
0.6.5 to 0.12.10 | None known |
gogsAlpine:v3.18 |
0.6.5 up to 0.13.0-r0 | 0.13.0-r0 |
gogsAlpine:v3.19 |
0.6.5 up to 0.13.0-r0 | 0.13.0-r0 |
gogsAlpine:v3.20 |
0.6.5 up to 0.13.0-r0 | 0.13.0-r0 |
gogs.io/gogsGo |
0.6.5 and later | None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| affected, aliases, facts, references | OSV | |
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-32174 is a critical vulnerability (CVSS 9.0) in Gogs, published October 11, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 58.2%, the 99th percentile. Fixed in gogs 0.13.0-r0.
References
mend.io/vulnerability-database/CVE-2022-32174
github.com/gogs/gogs/blob/v0.12.10/public/js/gogs.js
nvd.nist.gov/vuln/detail/CVE-2022-32174
pkg.go.dev/vuln/GO-2022-1060
github.com/advisories/GHSA-mcjj-2fvq-mc3r
security.alpinelinux.org/vuln/CVE-2022-32174
github.com/CVEProject/cvelistV5/tree/main/cves/2022/32xxx/CVE-2022-32174.json
github.com/gogs/gogs