CVE-2022-3275
Puppetlabs-apt Command Injection
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
Attack profile
How easy it is to exploit
- Attack vector
- Adjacent network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- High
- Availability
- High
Exploit likelihood
What each source reports
CVE List Score used
8.4
Puppetlabs-apt Command Injection
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3275- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
EUVDEUVD-2022-42672
8.4
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
EUVD-2022-42672- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - Updated
- 2026-11-03
NVD
8.4
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3275- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-78
- Updated
- 2026-11-02
OSV
9.8
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
CVE-2022-3275- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
OSVDEBIAN-CVE-2022-3275
9.8
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
DEBIAN-CVE-2022-3275- CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-03
OSVUBUNTU-CVE-2022-3275
8.4
Command injection is possible in the puppetlabs-apt module prior to version 9.0.0. A malicious actor is able to exploit this vulnerability only if they are able to provide unsanitized input to the module. This condition is rare in most deployments of Puppet and Puppet Enterprise.
- Record
UBUNTU-CVE-2022-3275- CVSS 3.1
- 8.4 High
CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
puppet-module-puppetlabs-aptDebian:12 |
before 9.0.1-1 | 9.0.1-1 |
puppet-module-puppetlabs-aptDebian:13 |
before 9.0.1-1 | 9.0.1-1 |
puppet-module-puppetlabs-aptDebian:14 |
before 9.0.1-1 | 9.0.1-1 |
puppet-module-puppetlabs-aptUbuntu:16.04:LTS |
All versions, plus listed versions 1.6.0-22.2.0-1 |
None known |
puppet-module-puppetlabs-aptUbuntu:18.04:LTS |
All versions, plus listed versions 2.3.0-14.4.1-14.5.1-1 |
None known |
puppet-module-puppetlabs-aptUbuntu:20.04:LTS |
All versions, plus listed versions 6.1.1-1 |
None known |
puppet-module-puppetlabs-aptUbuntu:22.04:LTS |
All versions, plus listed versions 6.1.1-1 |
None known |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-3275 is a high vulnerability (CVSS 8.4) in Puppet Puppetlabs-apt, published October 7, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.37%, the 83rd percentile. Fixed in puppet-module-puppetlabs-apt 9.0.1-1.
References
puppet.com/security/cve/CVE-2022-3275
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YR5LIOF5VKS4DC2NQWXTMPPXOYJC46XC
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CH4NUKZKPY4MFQHFBTONJK2AWES4DFDA
security-tracker.debian.org/tracker/CVE-2022-3275
ubuntu.com/security/CVE-2022-3275
github.com/puppetlabs/puppetlabs-apt/compare/v8.5.0...v9.0.0
github.com/puppetlabs/puppetlabs-apt/pull/1052
cve.org/CVERecord?id=CVE-2022-3275