CVE-2022-33156
brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
- Record
CVE-2022-33156- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
- Record
CVE-2022-33156- Updated
- 2026-11-02
EUVDEUVD-2022-6056 No score
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
- Record
EUVD-2022-6056- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-gvxv-p9rv-gmcg
6.1
brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
- Record
GHSA-gvxv-p9rv-gmcg- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-gvxv-p9rv-gmcg
6.1
brotkrueml/typo3-matomo-integration vulnerable to Cross-Site Scripting
The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
- Record
GHSA-gvxv-p9rv-gmcg- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVBIT-matomo-2022-33156 No score
The matomo_integration (aka Matomo Integration) extension before 1.3.2 for TYPO3 allows XSS.
- Record
BIT-matomo-2022-33156- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
brotkrueml/typo3-matomo-integrationPackagist |
before 1.3.2 | 1.3.2 |
matomoBitnami |
before 1.3.2 | 1.3.2 |
brotkrueml/typo3-matomo-integrationPackagist |
before 1.3.2, plus listed versions v1.0.0v1.0.1v1.1.0v1.2.0v1.3.0v1.3.1 |
1.3.2 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-33156 is a medium vulnerability (CVSS 6.1) in Matomo Integration, published June 17, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in brotkrueml/typo3-matomo-integration 1.3.2.