CVE-2022-33157
libconnect Extension for Typo3 Vulnerable to XSS
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
6.1
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
- Record
CVE-2022-33157- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 4.3 Medium
AV:N/AC:M/Au:N/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
- Record
CVE-2022-33157- Updated
- 2026-11-02
EUVDEUVD-2022-6314 No score
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
- Record
EUVD-2022-6314- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-c8f2-5h29-8j2h
6.1
libconnect Extension for Typo3 Vulnerable to XSS
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
- Record
GHSA-c8f2-5h29-8j2h- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-c8f2-5h29-8j2h
6.1
libconnect Extension for Typo3 Vulnerable to XSS
The libconnect extension before 7.0.8 and 8.x before 8.1.0 for TYPO3 allows XSS.
- Record
GHSA-c8f2-5h29-8j2h- CVSS 3.1
- 6.1 Medium
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
subhh/libconnectPackagist |
before 7.0.8 | 7.0.8 |
subhh/libconnectPackagist |
8.0.0 up to 8.1.0 | 8.1.0 |
subhh/libconnectPackagist |
before 7.0.8, plus listed versions 6.0.06.1.07.0.07.0.17.0.47.0.57.0.67.0.7 |
7.0.8 |
subhh/libconnectPackagist |
8.0.0 up to 8.1.0, plus listed versions 8.0.18.0.2 |
8.1.0 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-33157 is a medium vulnerability (CVSS 6.1) in Libconnect Project Libconnect, published July 12, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.57%, the 47th percentile. Fixed in subhh/libconnect 7.0.8.