Every CVE Search/ Get API key

CVE-2022-3355

Cross-site Scripting (XSS) - Stored in inventree/inventree

8.2 HighFix available

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

0.87%Unchanged since Sep 30, 2022
90%50%10%1%

What each source reports

CVE List Score used 8.2

Cross-site Scripting (XSS) - Stored in inventree/inventree

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.

Record
CVE-2022-3355
CVSS 3.0
8.2 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
EUVDEUVD-2022-6715 8.2

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.

Record
EUVD-2022-6715
CVSS 3.0
8.2 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-62g7-fpv9-v95f 5.4

Inventree vulnerable to Stored Cross-site Scripting

Inventree prior to 0.8.3 is vulnerable to stored cross-site scripting by uploading SVG files. Version 0.8.3 contains a patch for this issue.

Record
GHSA-62g7-fpv9-v95f
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
NVD 5.4

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.

Record
CVE-2022-3355
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
CVSS 3.0
8.2 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSV 8.2

Cross-site Scripting (XSS) - Stored in inventree/inventree

Cross-site Scripting (XSS) - Stored in GitHub repository inventree/inventree prior to 0.8.3.

Record
CVE-2022-3355
CVSS 3.0
8.2 HighCVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVGHSA-62g7-fpv9-v95f 5.4

Inventree vulnerable to Stored Cross-site Scripting

Inventree prior to 0.8.3 is vulnerable to stored cross-site scripting by uploading SVG files. Version 0.8.3 contains a patch for this issue.

Record
GHSA-62g7-fpv9-v95f
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weakness
CWE-79
Updated
2026-11-02
OSVPYSEC-2026-823 5.4

Inventree vulnerable to Stored Cross-site Scripting

Inventree prior to 0.8.3 is vulnerable to stored cross-site scripting by uploading SVG files. Version 0.8.3 contains a patch for this issue.

Record
PYSEC-2026-823
CVSS 3.1
5.4 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
inventree
PyPI
before 0.8.3
0.8.3
inventree
PyPI
before 0.8.3, plus listed versions
0.0.10.0.20.0.30.0.40.0.5
Show 22 moreShow less
0.0.60.0.70.0.80.0.90.1.00.1.10.1.20.1.30.1.40.2.40.3.10.3.20.4.40.6.00.6.10.7.00.7.10.7.20.7.30.8.00.8.10.8.2
0.8.3

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-3355 is a high vulnerability (CVSS 8.2) in Inventree Inventree/inventree, published September 29, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.87%, the 59th percentile. Fixed in inventree 0.8.3.

References

MoveEnter Open