Every CVE Search/ Get API key

CVE-2022-34112

Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

6.5 MediumFix available

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
None
Integrity
High
Availability
None

Exploit likelihood

0.61%Down 0.3 points since Jul 23, 2022
90%50%10%1%

What each source reports

NVD Score used 6.5

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Record
CVE-2022-34112
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-732
Updated
2026-11-02
CVE List No score

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Record
CVE-2022-34112
Updated
2026-11-02
EUVDEUVD-2022-6312 No score

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Record
EUVD-2022-6312
Updated
2026-11-03
GitHub AdvisoriesGHSA-c2pj-rr68-pw94 6.5

Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.

Record
GHSA-c2pj-rr68-pw94
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-732
Updated
2026-11-02
OSVGHSA-c2pj-rr68-pw94 6.5

Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.

Record
GHSA-c2pj-rr68-pw94
CVSS 3.1
6.5 MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weakness
CWE-732
Updated
2026-11-02
OSV No score

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator.

Record
CVE-2022-34112
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
io.dataease:dataease-plugin-common
Maven
through 1.11.1
1.11.2
io.dataease:dataease-plugin-common
Maven
before 1.11.2, plus listed versions
1.01.11.10.01.11.01.11.1
Show 8 moreShow less
1.21.31.41.51.61.71.8.01.9.0
1.11.2

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-34112 is a medium vulnerability (CVSS 6.5) in Dataease, published July 22, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 0.61%, the 49th percentile. Fixed in io.dataease:dataease-plugin-common 1.11.2.

References

MoveEnter Open