Every CVE Search/ Get API key

CVE-2022-34254

Adobe Commerce Improper Limitation of a Pathname to a Restricted Directory Arbitrary code execution

8.5 HighFix available

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
Low
User interaction
None

What an attacker can affect

Confidentiality
High
Integrity
Low
Availability
None

Exploit likelihood

2.33%Up 1.4 points since Aug 17, 2022
90%50%10%1%

What each source reports

CVE List Score used 8.5

Adobe Commerce Improper Limitation of a Pathname to a Restricted Directory Arbitrary code execution

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
CVE-2022-34254
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-22
Updated
2026-11-02
EUVDEUVD-2022-6554 8.5

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
EUVD-2022-6554
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Updated
2026-11-02
GitHub AdvisoriesGHSA-fx9g-g9q6-x3jx 8.5

Magento Path Traversal vulnerability

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
GHSA-fx9g-g9q6-x3jx
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-22
Updated
2026-11-02
NVD 8.8

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
CVE-2022-34254
CVSS 3.1
8.8 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-22
Updated
2026-11-02
OSV 8.5

Adobe Commerce Improper Limitation of a Pathname to a Restricted Directory Arbitrary code execution

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
CVE-2022-34254
CVSS 3.0
8.5 HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVGHSA-fx9g-g9q6-x3jx 8.5

Magento Path Traversal vulnerability

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
GHSA-fx9g-g9q6-x3jx
CVSS 3.1
8.5 HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
Weakness
CWE-22
Updated
2026-11-02
OSVBIT-magento-2022-34254 No score

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could be abused by an attacker to inject malicious scripts into the vulnerable endpoint. A low privileged attacker could leverage this vulnerability to read local files and to perform Stored XSS. Exploitation of this issue does not require user interaction.

Record
BIT-magento-2022-34254
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
magento/community-edition
Packagist
2.3.0 up to 2.3.7-p4
2.3.7-p4
magento/community-edition
Packagist
2.4.0 up to 2.4.3-p3
2.4.3-p3
magento/community-edition
Packagist
2.4.4 to 2.4.4
2.4.5
magento
Bitnami
2.3.0 up to 2.3.7, 2.4.0 up to 2.4.3, 2.3.7-p1 to 2.3.7-p1, 2.3.7-p2 to 2.3.7-p2, 2.3.7-p3 to 2.3.7-p3, 2.3.7 to 2.3.7, 2.4.3-p1 to 2.4.3-p1, 2.4.3-p2 to 2.4.3-p2, 2.4.3 to 2.4.3, 2.4.4 to 2.4.4
2.3.72.4.3
magento/community-edition
Packagist
2.3.0 up to 2.3.7-p4, plus listed versions
2.3.12.3.22.3.2-p22.3.32.3.3-p1
Show 11 moreShow less
2.3.42.3.4-p22.3.52.3.5-p12.3.5-p22.3.62.3.6-p12.3.72.3.7-p12.3.7-p22.3.7-p3
2.3.7-p4
magento/community-edition
Packagist
2.4.0 up to 2.4.3-p3, plus listed versions
2.4.0-p12.4.12.4.1-p12.4.22.4.2-p1
Show 4 moreShow less
2.4.2-p22.4.32.4.3-p12.4.3-p2
2.4.3-p3
magento/community-edition
Packagist
2.4.4 up to 2.4.5, plus listed versions
2.4.4-p12.4.4-p102.4.4-p112.4.4-p122.4.4-p13
Show 8 moreShow less
2.4.4-p22.4.4-p32.4.4-p42.4.4-p52.4.4-p62.4.4-p72.4.4-p82.4.4-p9
2.4.5

History

History
RecordedChangedSources
first indexedCVE List, EUVD, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-34254 is a high vulnerability (CVSS 8.5) in Adobe Commerce, published August 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.33%, the 83rd percentile. Fixed in magento/community-edition 2.3.7-p4.

References

MoveEnter Open