CVE-2022-34256
Adobe Commerce Improper Authorization Privilege escalation
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
7.5
Adobe Commerce Improper Authorization Privilege escalation
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
CVE-2022-34256- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
EUVDEUVD-2022-6615
7.5
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
EUVD-2022-6615- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-r7mm-grf3-5fjv
7.5
Magento Improper Authorization vulnerability
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
GHSA-r7mm-grf3-5fjv- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
NVD
7.5
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
CVE-2022-34256- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - CVSS 3.1
- 9.8 Critical
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H - Weakness
- CWE-285
- Updated
- 2026-11-02
OSV
7.5
Adobe Commerce Improper Authorization Privilege escalation
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
CVE-2022-34256- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-285
- Updated
- 2026-11-02
OSVGHSA-r7mm-grf3-5fjv
7.5
Magento Improper Authorization vulnerability
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
GHSA-r7mm-grf3-5fjv- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-285, CWE-863
- Updated
- 2026-11-02
OSVBIT-magento-2022-34256 No score
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
- Record
BIT-magento-2022-34256- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
magento/community-editionPackagist |
2.3.0 up to 2.3.7-p4 | 2.3.7-p4 |
magento/community-editionPackagist |
2.4.4 up to 2.4.5 | 2.4.5 |
magento/community-editionPackagist |
2.4.0 up to 2.4.3-p3 | 2.4.3-p3 |
magentoBitnami |
2.3.0 up to 2.3.7, 2.4.0 up to 2.4.3, 2.3.7-p1 to 2.3.7-p1, 2.3.7-p2 to 2.3.7-p2, 2.3.7-p3 to 2.3.7-p3, 2.3.7 to 2.3.7, 2.4.3-p1 to 2.4.3-p1, 2.4.3-p2 to 2.4.3-p2, 2.4.3 to 2.4.3, 2.4.4 to 2.4.4 | 2.3.72.4.3 |
magento/community-editionPackagist |
2.3.0 up to 2.3.7-p4, plus listed versions 2.3.12.3.22.3.2-p22.3.32.3.3-p1 Show 11 moreShow less2.3.42.3.4-p22.3.52.3.5-p12.3.5-p22.3.62.3.6-p12.3.72.3.7-p12.3.7-p22.3.7-p3 |
2.3.7-p4 |
magento/community-editionPackagist |
2.4.4 up to 2.4.5, plus listed versions 2.4.4-p12.4.4-p102.4.4-p112.4.4-p122.4.4-p13 Show 8 moreShow less2.4.4-p22.4.4-p32.4.4-p42.4.4-p52.4.4-p62.4.4-p72.4.4-p82.4.4-p9 |
2.4.5 |
magento/community-editionPackagist |
2.4.0 up to 2.4.3-p3, plus listed versions 2.4.0-p12.4.12.4.1-p12.4.22.4.2-p1 Show 4 moreShow less2.4.2-p22.4.32.4.3-p12.4.3-p2 |
2.4.3-p3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-34256 is a high vulnerability (CVSS 7.5) in Adobe Commerce, published August 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 2.21%, the 82nd percentile. Fixed in magento/community-edition 2.3.7-p4.
References
helpx.adobe.com/security/products/magento/apsb22-38.html
nvd.nist.gov/vuln/detail/CVE-2022-34256
github.com/magento/magento2/commit/246d524b7586af2245092008e0d92b8d6fdd8523
github.com/magento/magento2/commit/5548bc64b5bc904346c0af9193a7fbb5274b4efa
github.com/magento/magento2/commit/5f07eba878296a37bd5c3a2baecad48948547594
github.com/advisories/GHSA-r7mm-grf3-5fjv
github.com/CVEProject/cvelistV5/tree/main/cves/2022/34xxx/CVE-2022-34256.json
github.com/magento/magento2