CVE-2022-34258
Adobe Commerce Stored XSS Arbitrary code execution
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- High
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
CVE List Score used
4.8
Adobe Commerce Stored XSS Arbitrary code execution
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
CVE-2022-34258- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
EUVDEUVD-2022-6487
4.8
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
EUVD-2022-6487- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
GitHub AdvisoriesGHSA-5m55-g8pv-x8ww
5.5
Magento stored Cross-Site Scripting (XSS) vulnerability
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
GHSA-5m55-g8pv-x8ww- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
NVD
4.8
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
CVE-2022-34258- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
4.8
Adobe Commerce Stored XSS Arbitrary code execution
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
CVE-2022-34258- CVSS 3.1
- 4.8 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVGHSA-5m55-g8pv-x8ww
5.5
Magento stored Cross-Site Scripting (XSS) vulnerability
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
GHSA-5m55-g8pv-x8ww- CVSS 3.1
- 5.5 Medium
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
OSVBIT-magento-2022-34258 No score
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
- Record
BIT-magento-2022-34258- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
magento/community-editionPackagist |
2.3.0 up to 2.3.7-p4 | 2.3.7-p4 |
magento/community-editionPackagist |
2.4.4 up to 2.4.5 | 2.4.5 |
magento/community-editionPackagist |
2.4.0 up to 2.4.3-p3 | 2.4.3-p3 |
magentoBitnami |
2.3.0 up to 2.3.7, 2.4.0 up to 2.4.3, 2.3.7-p1 to 2.3.7-p1, 2.3.7-p2 to 2.3.7-p2, 2.3.7-p3 to 2.3.7-p3, 2.3.7 to 2.3.7, 2.4.3-p1 to 2.4.3-p1, 2.4.3-p2 to 2.4.3-p2, 2.4.3 to 2.4.3, 2.4.4 to 2.4.4 | 2.3.72.4.3 |
magento/community-editionPackagist |
2.3.0 up to 2.3.7-p4, plus listed versions 2.3.12.3.22.3.2-p22.3.32.3.3-p1 Show 11 moreShow less2.3.42.3.4-p22.3.52.3.5-p12.3.5-p22.3.62.3.6-p12.3.72.3.7-p12.3.7-p22.3.7-p3 |
2.3.7-p4 |
magento/community-editionPackagist |
2.4.4 up to 2.4.5, plus listed versions 2.4.4-p12.4.4-p102.4.4-p112.4.4-p122.4.4-p13 Show 8 moreShow less2.4.4-p22.4.4-p32.4.4-p42.4.4-p52.4.4-p62.4.4-p72.4.4-p82.4.4-p9 |
2.4.5 |
magento/community-editionPackagist |
2.4.0 up to 2.4.3-p3, plus listed versions 2.4.0-p12.4.12.4.1-p12.4.22.4.2-p1 Show 4 moreShow less2.4.2-p22.4.32.4.3-p12.4.3-p2 |
2.4.3-p3 |
History
| Recorded | Changed | Sources |
|---|---|---|
| first indexed | CVE List, EUVD, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-34258 is a medium vulnerability (CVSS 4.8) in Adobe Commerce, published August 16, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 69.9%, the 99th percentile. Fixed in magento/community-edition 2.3.7-p4.
References
helpx.adobe.com/security/products/magento/apsb22-38.html
nvd.nist.gov/vuln/detail/CVE-2022-34258
github.com/magento/magento2/commit/246d524b7586af2245092008e0d92b8d6fdd8523
github.com/magento/magento2/commit/5548bc64b5bc904346c0af9193a7fbb5274b4efa
github.com/magento/magento2/commit/5f07eba878296a37bd5c3a2baecad48948547594
github.com/advisories/GHSA-5m55-g8pv-x8ww
github.com/CVEProject/cvelistV5/tree/main/cves/2022/34xxx/CVE-2022-34258.json
github.com/magento/magento2