Every CVE Search/ Get API key

CVE-2022-34299

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to...

8.1 HighFix available

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Attack profile

How easy it is to exploit

Attack vector
Network
Complexity
Low
Privileges needed
None
User interaction
Required

What an attacker can affect

Confidentiality
High
Integrity
None
Availability
High

Exploit likelihood

1.43%Up 0.5 points since Jun 23, 2022
90%50%10%1%

What each source reports

NVD Score used 8.1

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
CVE-2022-34299
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
CVSS 2.0
5.8 MediumAV:N/AC:M/Au:N/C:P/I:N/A:P
Weakness
CWE-125
Updated
2026-11-02
CVE List No score

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
CVE-2022-34299
Updated
2026-11-02
EUVDEUVD-2022-37256 No score

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
EUVD-2022-37256
Updated
2026-11-03
GitHub AdvisoriesGHSA-3j8p-q74h-4pxp 8.1

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to...

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
GHSA-3j8p-q74h-4pxp
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Weakness
CWE-125
Updated
2026-11-02
OSVDEBIAN-CVE-2022-34299 8.1

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
DEBIAN-CVE-2022-34299
CVSS 3.1
8.1 HighCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:H
Updated
2026-11-03
OSV No score

There is a heap-based buffer over-read in libdwarf 0.4.0. This issue is related to dwarf_global_formref_b.

Record
CVE-2022-34299
Updated
2026-11-02
OSVopenSUSE-SU-2024:12509-1 No score

libdwarf-devel-0.4.2-2.1 on GA media

These are all security issues fixed in the libdwarf-devel-0.4.2-2.1 package on the GA media of openSUSE Tumbleweed.

Record
openSUSE-SU-2024:12509-1
Updated
2026-11-02

Affected products

Affected packages

Affected packages
PackageAffectedFixed
dwarfutils
Debian:12
All versions, plus listed versions
1:0.11.1-11:0.11.1-1~exp11:0.11.1-1~exp220210528-1
None known
dwarfutils
Debian:13
before 1:0.11.1-1
1:0.11.1-1
dwarfutils
Debian:14
before 1:0.11.1-1
1:0.11.1-1

History

History
RecordedChangedSources
aliasesEUVD
first indexedCVE List, GitHub Advisories, NVD, OSV

Dates are when Every CVE recorded each change. Upstream dates may differ.

In short

CVE-2022-34299 is a high vulnerability (CVSS 8.1) in Libdwarf Project Libdwarf, published June 22, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 1.43%, the 73rd percentile. Fixed in dwarfutils 1:0.11.1-1.

References

MoveEnter Open