CVE-2022-34783
Cross-site Scripting in Jenkins Plot Plugin
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- Low
- User interaction
- Required
What an attacker can affect
- Confidentiality
- Low
- Integrity
- Low
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
5.4
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
CVE-2022-34783- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - CVSS 2.0
- 3.5 Low
AV:N/AC:M/Au:S/C:N/I:P/A:N - Weakness
- CWE-79
- Updated
- 2026-11-02
CVE List No score
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
CVE-2022-34783- Updated
- 2026-11-02
EUVDEUVD-2022-6352 No score
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
EUVD-2022-6352- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-hpf7-mmqw-g6vq
8.0
Cross-site Scripting in Jenkins Plot Plugin
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
GHSA-hpf7-mmqw-g6vq- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
OSV
5.4
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
CVE-2022-34783- CVSS 3.1
- 5.4 Medium
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N - Updated
- 2026-11-02
OSVGHSA-hpf7-mmqw-g6vq
8.0
Cross-site Scripting in Jenkins Plot Plugin
Jenkins Plot Plugin 2.1.10 and earlier does not escape plot descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
- Record
GHSA-hpf7-mmqw-g6vq- CVSS 3.1
- 8.0 High
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H - Weakness
- CWE-79
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
org.jenkins-ci.plugins:plotMaven |
before 2.1.11 | 2.1.11 |
org.jenkins-ci.plugins:plotMaven |
before 2.1.11, plus listed versions 1.111.51.61.71.8 Show 17 moreShow less1.92.0.02.0.22.0.32.0.42.0.52.1.02.1.12.1.102.1.22.1.32.1.42.1.52.1.62.1.72.1.82.1.9 |
2.1.11 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-34783 is a medium vulnerability (CVSS 5.4) in Jenkins Plot, published June 30, 2022. No source lists public exploit code. EPSS puts the chance of exploitation in the next 30 days at 81.8%, the 99th percentile. Fixed in org.jenkins-ci.plugins:plot 2.1.11.