CVE-2022-35650
Moodle Arbitrary file read when importing lesson questions
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
Attack profile
How easy it is to exploit
- Attack vector
- Network
- Complexity
- Low
- Privileges needed
- None
- User interaction
- None
What an attacker can affect
- Confidentiality
- High
- Integrity
- None
- Availability
- None
Exploit likelihood
What each source reports
NVD Score used
7.5
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
CVE-2022-35650- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-22, CWE-20
- Updated
- 2026-11-02
CVE List No score
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
CVE-2022-35650- Weakness
- CWE-22
- Updated
- 2026-11-02
EUVDEUVD-2022-6384 No score
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
EUVD-2022-6384- Updated
- 2026-11-03
GitHub AdvisoriesGHSA-pgm5-cr62-prxq
7.5
Moodle Arbitrary file read when importing lesson questions
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
GHSA-pgm5-cr62-prxq- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVGHSA-pgm5-cr62-prxq
7.5
Moodle Arbitrary file read when importing lesson questions
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
GHSA-pgm5-cr62-prxq- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Weakness
- CWE-20
- Updated
- 2026-11-02
OSVUBUNTU-CVE-2022-35650
7.5
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
UBUNTU-CVE-2022-35650- CVSS 3.1
- 7.5 High
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N - Updated
- 2026-11-02
OSVBIT-moodle-2022-35650 No score
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
BIT-moodle-2022-35650- Updated
- 2026-11-02
OSV No score
The vulnerability was found in Moodle, occurs due to input validation error when importing lesson questions. This insufficient path checks results in arbitrary file read risk. This vulnerability allows a remote attacker to perform directory traversal attacks. The capability to access this feature is only available to teachers, managers and admins by default.
- Record
CVE-2022-35650- Weakness
- CWE-22
- Updated
- 2026-11-02
Affected products
Affected packages
| Package | Affected | Fixed |
|---|---|---|
moodle/moodlePackagist |
3.9 up to 3.9.15 | 3.9.15 |
moodle/moodlePackagist |
3.11 up to 3.11.8 | 3.11.8 |
moodle/moodlePackagist |
4.0 up to 4.0.2 | 4.0.2 |
moodleBitnami |
3.9.0 up to 3.9.15, 3.11.0 up to 3.11.8, 4.0.0 up to 4.0.2 | 3.9.153.11.84.0.2 |
moodle/moodlePackagist |
3.9 up to 3.9.15, plus listed versions v3.9.0v3.9.0-betav3.9.0-rc1v3.9.0-rc2v3.9.0-rc3 Show 14 moreShow lessv3.9.1v3.9.10v3.9.11v3.9.12v3.9.13v3.9.14v3.9.2v3.9.3v3.9.4v3.9.5v3.9.6v3.9.7v3.9.8v3.9.9 |
3.9.15 |
moodle/moodlePackagist |
3.11 up to 3.11.8, plus listed versions v3.11.0v3.11.0-betav3.11.0-rc1v3.11.0-rc2v3.11.1 Show 6 moreShow lessv3.11.2v3.11.3v3.11.4v3.11.5v3.11.6v3.11.7 |
3.11.8 |
moodle/moodlePackagist |
4.0 up to 4.0.2, plus listed versions v4.0.0v4.0.0-betav4.0.0-rc1v4.0.0-rc2v4.0.0-rc3v4.0.0-rc4v4.0.1 |
4.0.2 |
moodleUbuntu:Pro:16.04:LTS |
All versions, plus listed versions 2.7.9+dfsg-12.7.10+dfsg-12.7.11+dfsg-12.7.11+dfsg-22.7.12+dfsg-13.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
moodleUbuntu:Pro:18.04:LTS |
All versions, plus listed versions 3.0.3+dfsg-0ubuntu13.0.3+dfsg-0ubuntu1+esm1 |
None known |
Public exploits
Links only. Every CVE stores no exploit code.
| Source | Link | Date |
|---|---|---|
| PoC in GitHub | Gr4y-r0se/CVE-2022-35650 | 2026-04-15 |
History
| Recorded | Changed | Sources |
|---|---|---|
| aliases | EUVD | |
| first indexed | CVE List, GitHub Advisories, NVD, OSV, PoC in GitHub |
Dates are when Every CVE recorded each change. Upstream dates may differ.
In short
CVE-2022-35650 is a high vulnerability (CVSS 7.5) in Moodle, published July 25, 2022. Public exploit code exists. EPSS puts the chance of exploitation in the next 30 days at 53.7%, the 99th percentile. Fixed in moodle/moodle 3.9.15.
References
bugzilla.redhat.com/show_bug.cgi?id=2106274
moodle.org/mod/forum/discuss.php?d=436457
git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-72029
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3
lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V
nvd.nist.gov/vuln/detail/CVE-2022-35650
Show 7 moreShow less
lists.fedoraproject.org/archives/list/[email protected]/message/6MOKYVRNFNAODP2XSMGJ5CRDUZCZKAR3
lists.fedoraproject.org/archives/list/[email protected]/message/MTKUSFPSYFINSQFSOHDQIDVE6FWBEU6V
github.com/advisories/GHSA-pgm5-cr62-prxq
github.com/CVEProject/cvelistV5/tree/main/cves/2022/35xxx/CVE-2022-35650.json
github.com/moodle/moodle
ubuntu.com/security/CVE-2022-35650
cve.org/CVERecord?id=CVE-2022-35650